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1.0 Introduction 

 

This tutorial introduces the fracture simulation capabilities of FRANC3D Version 8 and 

ABAQUS 2022; other versions of ABAQUS should work also.  FRANC3D is introduced by 

analyzing a single surface crack in an ABAQUS finite element (FE) model of a cube.  

 

Subsequent tutorials (see the FRANC3D Tutorials #2-14 document) build on this first example 

and describe additional capabilities and features of the software.  It is intended that the user 

perform operations as they are presented, but you are free to experiment and consult the other 

reference documentation whenever necessary. 

 

The FRANC3D menu and dialog button selections are indicated by bold text, such as File menu.  

Window regions along with dialog options, fields and labels are underlined.  Model names and 

file names are indicated by italic text.   

 

The FRANC3D main window is shown in Fig 1.1.  When you start the tutorial, the first thing to 

do is set the working directory using the File →Work Directory menu option, Fig 1.1.  

 

Before or after a model is imported, you can set the FE model units, Fig 1.2.  The selected units 

are applied to plots and figures that FRANC3D might display and are used during crack growth 

in combination with fatigue crack growth rate data, which also has units.  

 

You can also set your preferences; it is helpful to set the path to the ABAQUS executable.  You 

can view the preferences using the Edit and Preferences menu option.  The Preferences dialog is 

described in Section 5.4 of the FRANC3D Reference document. 
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Figure 1.1  FRANC3D main window – Work Directory menu option. 

 

 

    

Figure 1.2  FRANC3D FE model unit conversion menu option and dialog. 
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2.0 Tutorial 1: Crack Insertion and Growth in a Cube 

 

In this tutorial, a single surface crack in a cube under far-field tension is modeled.  It is assumed 

that the user is familiar with a pre-processor for ABAQUS; we use ABAQUS CAE.  Once the 

FE model is created, the FRANC3D steps to: 1) read the model, 2) insert a crack, 3) perform the 

ABAQUS analysis, and 4) compute stress intensity factors, are all described.  

 

2.1 Step 1:  Create the ABAQUS FE Model  

 

First, you must create a cube model using any pre-processor for ABAQUS.  We outline the steps 

to create the FE model with boundary conditions to ensure that you have a model that can be 

used with FRANC3D.   

 

1. Create a 10x10x10 cube geometry; units of length are mm. 

2. Subdivide the edges for meshing, using 10 to 20 subdivisions. 

3. Define the element type as quadratic; use brick or tetrahedral elements to mesh the 

volume. 

4. Define the material properties; elastic modulus (E) is 10000 and Poisson’s ratio is 0.3; 

units for E are MPa. 

5. Boundary conditions consist of displacement constraints on the bottom surface and 

uniform traction (a negative pressure) on the top surface. The bottom surface is 

constrained in the y-direction, the bottom left edge is also constrained in the x-direction, 

and the point at the origin is also constrained in the z-direction.  The top surface traction 

is 10 MPa. 

6. Write the .inp file (Abaqus_Cube.inp).  

 

The resulting model is shown in Fig 2.1.  The symbols for the boundary conditions are displayed 

attached to the model; the brick mesh is displayed in the lower right corner. 
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Figure 2.1  ABAQUS cube with boundary conditions; meshed with brick elements. 

 

 

Note that ABAQUS CAE uses default set and surface names such as SET-1 at both the Part and 

Instance levels, Fig 2.2.  Instance SET-1 can be both a node and an element set.  If boundary 

conditions are applied in CAE using the Instance SET-1 (right side image), FRANC3D might 

apply the boundary conditions to both Part and Instance SET-1 nodes.  

 

The solution is to name sets and surfaces in CAE with unique names, especially when defining 

boundary conditions. 
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Figure 2.2  ABAQUS CAE Set-1 at both Part and Instance levels. 

 

 

2.2 Step 2:  Reading ABAQUS FE Model into FRANC3D 

 

Once the ABAQUS FE model is created and the .inp file is saved, we can proceed with 

importing the FE model into FRANC3D.  We use the Abaqus_Cube.inp file from ABAQUS 

CAE that was created in the previous step.  

 

You can choose to do either this Step 2 or Step 3 (see Section 2.3). 

 

Step 2.1: Importing Complete ABAQUS FE Model  

 

Start with the FRANC3D graphical user interface (see Fig 1.1) and select File →Import, Fig 

2.3.  In the dialog shown in Fig 2.4, choose Complete Model and select Next.  

 

 

Figure 2.3  File Import menu option. 
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Figure 2.4  Model Import Type dialog. 

 

Switch the Mesh File Type radio button in the Select Import Mesh File window, Fig 2.5, to 

ABAQUS and select the file name for the model, Abaqus_Cube.inp, and then select Next.   

 

Note that the mesh file type can be set in the Preferences so that you do not have to change the 

mesh file type radio button if you always use ABAQUS. 

 

 

Figure 2.5  Select Input Mesh File dialog box. 
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Step 2.2: Select the Retained Items in the FE Model 

 

The next panel, Fig 2.6, allows you to choose the mesh surface facets that are retained from the 

ABAQUS .inp file.  Surfaces with boundary conditions are blue, Fig 2.7, and turn red when 

selected, Fig 2.8.  You can rotate the model to view all surfaces.  We retain the surfaces with 

boundary conditions (top and bottom of the cube) by choosing Select All.  The boundary 

conditions will be transferred automatically to the new mesh once a crack is inserted.  

 

Select Next to proceed. The Units dialog will be displayed; if you have already set the units 

using the Edit menu, just select Finish. 

 

 

 

Figure 2.6  Select Retained BC Surfaces wizard panel. 
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Figure 2.7  ABAQUS Model retain BC Surfaces wizard panel - Unselected Surface 

 

 

Figure 2.8  ABAQUS Model retain BC Surfaces wizard panel – Selected Surface 
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Surface Mesh NOT Retained  

 

The surface mesh facets do not have to be retained, and if a crack is inserted into a surface that 

has boundary conditions, then the surface mesh must not be retained.  In such a case, the 

boundary condition data is mapped to the remeshed surface.  In practice, transfer of boundary 

condition data is simpler and more precise if the surface mesh is retained, but sometimes this is 

not possible. FRANC3D will automatically transfer the boundary condition data to the new mesh 

in either case. 

 

Step 2.3: Displaying the FE Model 

 

The model is displayed in the FRANC3D modeling window, Fig 2.9.  You can turn on the 

surface mesh, or manipulate the model view by rotating, etc.  Fig 2.9 shows the retained mesh on 

the top surface (retained bottom surface not visible) where the traction boundary conditions are 

applied.  See Section 2 of the Reference document for a description of the view manipulation. 

 

 

Figure 2.9  ABAQUS model imported into FRANC3D with retained facets on the top surface. 
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If you have not set a working directory (using the File →Work Directory menu option), 

FRANC3D might present the dialog shown in Fig 2.10 prior to displaying the model.  Select Yes 

to set the work directory as the folder containing the ABAQUS .inp file.  Many files can be 

created during a crack growth simulation, and it is best to keep them together in one folder. 

 

 

Figure 2.10  Set Working Directory dialog. 

 

2.3 Step 3: Importing and Subdividing the Model 

 

If you chose to do Step 2 above, either skip this step, or close the model using the File →Close 

menu option before starting this step.  

 

The ABAQUS model can be split into smaller parts before inserting the crack. Go to File 

→Import and choose the Import and divide into global and local models radio button, Fig 2.11. 

Select Next, and then choose the Abaqus_Cube.inp model, Fig 2.12.  Remember to set the Mesh 

File Type radio button to ABAQUS. 

 

 

Figure 2.11  Model Import Type dialog with Import and divide selected. 
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Figure 2.12  Select Input Mesh File selection. 

 

 

Instead of the Retain BC Surfaces dialog (see Fig 2.6), the Define a Local Submodel window, 

Fig 2.13, appears. Figs 2.14 and 2.15 show two of the submodel selection tools. Using the 

options on the left, a submodel is selected; elements to be retained in the submodel appear red, 

and the selection is confirmed using the Crop button.  See Section 4.5 of the Reference 

document for a more complete description of the submodeling tools. 

 

For this tutorial, the rectangular Rubberband Box is used to create a smaller portion of the cube, 

Fig 2.16, which has an exposed face for crack insertion. 
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Figure 2.13  Define a Local Submodel Window 

 

 

 

Figure 2.14  Plane Cutting tool – Crop will retain red elements. 
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Figure 2.15  Element-by-Element cropping by selecting elements to remove. 

 

 

We are inserting a surface crack that is normal to the y-axis (loading direction) and located on 

the +z surface, and the selection in Fig 2.16 is designed for this.  Use the Rectangular option of 

the Rubberband Box to select and Crop a small portion of the model. 

 

  

  

Figure 2.16  Rectangular Rubberband Box tool used to select a submodel. 
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Once the elements have been selected and cropped, select Next.  The Save Files dialog appears, 

Fig 2.17.  Choose the names of the local and global models and their location; we use the default 

file names and the working directory that was set earlier. Select Next. 

 

 

Figure 2.17  Local/Global model save dialog. 

 

 

If the local cropped model has a surface with boundary conditions, then the Select Retained BC 

Surfaces window (see Fig 2.6) appears. Otherwise, the local model appears in the FRANC3D 

main window, with retained mesh surfaces wherever the local and global models connect (the cut 

surfaces).   

 

In this case, the cropped selection in Fig 2.16 avoids all surfaces with boundary conditions.  

However, if there are ABAQUS node sets or surfaces in the local model, then the Select 

Retained BC Surfaces window might still be displayed, Fig 2.18.  Just select Next to proceed. 

 

The model units, Fig 2.19, must be set.  As defined in Step 1, the units for length are mm and the 

units for stress are MPa.  The temperature and time units are not needed for this tutorial. 

 

Select Finish and the local model is displayed in the main FRANC3D window, Fig 2.20.  The 

cut-surface mesh facets are retained, while the front surface, where the crack will be inserted, 

does not have retained facets.  
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Figure 2.18  Select Retained BC Surfaces wizard panel – showing named node sets. 

 

 

 

Figure 2.19  FE Model units 
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Figure 2.20  Local model with retained mesh facets on the cut-surface. 

 

 

2.4 Step 4: Insert a Crack 

 

We now insert a half-penny surface crack into the model. The local submodel from Section 2.3 is 

used, as opposed to the full model from Section 2.2.  In Step 4.1, we describe how to define a 

new crack, and in Step 4.2, we describe how to insert a flaw from a file.   

 

Note that you cannot insert a crack into a cracked model.  If you want to try both types of crack 

insertion, you will have to re-import the uncracked model to insert a crack from a file; inserting a 

crack from a file will be used in subsequent steps and other tutorials. 

 

Step 4.1: Define a new Crack from FRANC3D Menu 

 

From the FRANC3D menu, select Cracks →New Flaw Wizard, Fig 2.21.  The first panel of the 

wizard, Fig 2.22, allows you to select the flaw type; a crack with zero volume is the default.  We 

select the Save to file and add flaw radio button so that the .crk file is saved for subsequent 
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tutorials.  Note that the Symmetry surface crack option is only displayed if symmetry cracks are 

turned on in the Preferences (see Section 5.2 in the Reference).  

 

Select Next.  The second panel, Fig 2.23, lets you choose the crack shape; the default is the 

ellipse, which is what we want.  Select Next. 

 

 

 

Figure 2.21  New Flaw Wizard menu item selected. 
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Figure 2.22  New Flaw Wizard first panel – Crack (zero volume flaw) selected. 

 

 

 

Figure 2.23  New Flaw Wizard second panel – choose ellipse shape. 
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The crack is a circle with radius=1, centered on the cube’s front (+z) face, and parallel to the xz-

plane (normal to y).  The third wizard panel lets you set the dimensions for the ellipse, Fig 2.24; 

set a=1 and b=1.  Select Next. 

 

 

Figure 2.24  New Flaw Wizard third panel – set ellipse dimensions. 

 

 

The fourth panel lets you set the crack location and orientation, Fig 2.25.  We place the crack at 

the center of the front face at coordinates (5,5,10) and rotate the crack 90 degrees about the 

Global x-axis.  Select Next. 

 

The final panel allows you to set the crack front mesh template parameters, Fig 2.26; use the 

defaults.  In practice, the default template radius is based on the crack dimensions and might 

need to be adjusted depending on the model and crack.  Select Finish.   
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Figure 2.25  New Flaw Wizard fourth panel – set crack location and orientation. 

 

 

 

Figure 2.26  New Flaw Wizard final panel – set template mesh parameters. 

 

 

At this point, you will be asked to specify the .crk file name, Fig 2.27; we call it 

Cube_Crack.crk.  Select Accept. 
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Figure 2.27  New Flaw Wizard final panel – save file as. 

 

 

The crack is inserted into the model and remeshing occurs.  A Flaw Insertion Status window is 

displayed during this process, Fig 2.28.  There are four stages:  geometric intersection of the 

crack with the model, surface meshing, volume meshing, and smoothing of the volume mesh.  

The resulting model is displayed in the main FRANC3D window, Fig 2.29; the surface mesh is 

turned on in this image. 

 

 

 

Figure 2.28  Flaw Insertion Status window. 
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Figure 2.29  Remeshed cracked local model with surface mesh turned on. 

 

 

Step 4.2: Insert Cracks from Files 

 

If you want to try this step, you must Close the model from Step 4.1 and re-import the original 

uncracked (local) model.  

 

From the FRANC3D menu, select Cracks →Flaw From Files, Fig 2.30.  The first panel, Fig 

2.31, lets you select the .crk file.  Choose the Cube_Crack.crk file name and select Accept. The 

flaw being added is a circle with radius=1, centered on the cube’s front face, and parallel to the 

xz-plane.   

 

This crack was created using the New Flaw Wizard with the save to file option in Step 4.1. 
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Figure 2.30  Flaw From Files option in Crack menu. 

 

 

Figure 2.31  Flaw from file dialog to select .crk file. 
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The next panel, Fig 2.32, allows you to adjust the location of the flaw.  The orientation cannot be 

changed.  The final panel, Fig 2.33, allows you to set the template mesh parameters. Use the 

default settings and select Finish to complete the insertion and remeshing. 

 

 

Figure 2.32  Flaw wizard panel to set location. 

 

 

Figure 2.33  Flaw geometry shown in the model with crack template mesh. 
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2.5  Step 5:  Static Crack Analysis 

 

Once the crack is inserted and the model is remeshed, we perform a stress analysis using 

ABAQUS, which provides the displacement results that are needed to compute stress intensity 

factors (SIFs).  Typically, you would run a “static crack analysis” of the initial crack prior to 

running automated crack growth; this allows you to verify that the crack model is consistent with 

the uncracked model.  You can compare displacement contours, using the ABAQUS post-

processor, for the original uncracked and the cracked models to verify that the crack model is 

valid. 

 

You might also insert the crack with a bigger or smaller template radius to verify that the 

computed SIFs are accurate; there should be no notable change in SIFs for a reasonable template. 

 

Step 5.1: Select Static Crack Analysis 

 

From the FRANC3D menu, select Analysis →Static Crack Analysis, Fig 2.34.  The first panel, 

Fig 2.35, requests that you enter the file name for the FRANC3D data.  We call it 

Abaqus_Cube_Subdivide.fdb; select Next once you enter a File Name.   

 

Note that you cannot use the initial uncracked Abaqus_Cube.inp or Abaqus_Cube_LOCAL.inp 

file names, because a new .inp file will be created during the analysis.  The original uncracked 

.inp files are reused for each step of crack growth. 
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Figure 2.34  Static Crack Analysis menu 

 

 

 

Figure 2.35  Static Analysis wizard first panel – File Name 

 



30 

 

 

Step 5.2: Select FE Solver 

 

The next panel, Fig 2.36, allows you to specify the solver; choose ABAQUS and select Next 

(button not shown in Fig 2.36).  If this panel does not show up, the ABAQUS solver has been 

chosen automatically. 

 

 

Figure 2.36  Static Analysis wizard second panel – choose solver. 

 

 

Step 5.3: Select ABAQUS Analysis Options 

 

The next panel, Fig 2.37, allows you to specify the ABAQUS output and analysis options.  The 

model is a sub-model and must be connected to the global model, so the Connect to global model 

box is checked automatically if the FRANC3D submodeler tool was used.  The next panel, Fig 

2.38, allows you to set the local + global model connection.  

 

Note that if the model being analyzed is a full/complete model, the panel in Fig 2.37 is the final 

panel as there is no global model, and the Next button will be a Finish button. 

 

Fig 2.38 shows the options for joining the local and global models. AUTO_CUT_SURF and 

GLOBAL_CONNECT_SURF are the node sets created by the FRANC3D submodeling tool and 

should be selected automatically.  Click Finish to start ABAQUS running (in batch/background 

mode).  FRANC3D writes files and then attempts to execute ABAQUS based on the ABAQUS 

Executable information (Fig 2.37). You can monitor the FRANC3D CMD window and the 

ABAQUS .dat and .msg files for errors or messages. 
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Figure 2.37  Static Analysis wizard third panel – ABAQUS output options 

 

 

Figure 2.38  Local/Global model connection 
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Note that if ABAQUS does not run, you will see a message in FRANC3D indicating that SIFs 

cannot be computed because there are no displacements, or you might see a message indicating 

that FRANC3D cannot find or open the .dtp file.  You can review the ABAQUS files for errors.  

The ABAQUS executable (and path to it) will depend on the installation and operating system. 

For MS Windows, for a typical installation, the executable is “abaqus.bat”, and is in the folder 

“C:\SIMULIA\Commands”. 

 

Choosing Write files but DO NOT run analysis in Fig 2.38 will create all the files without 

running ABAQUS, if the analysis needs to be run later or on a different computer.  

 

If you need to run ABAQUS on a different computer, you must bring the results file (.dtp) back 

to the working folder, and then you can use the File →Read Results menu option to import the 

results into FRANC3D.  The .dtp file is created by running the writeDtpFile.py script, which 

FRANC3D writes; the script extracts data from the .odb file.  

 

In a CMD or Terminal window, the command is:  

  > abaqus python writeDtpFile.py 

 

 

2.6  Step 6:  Compute Stress Intensity Factors 

 

Once the ABAQUS analysis is done, we can compute SIFs.  From the FRANC3D menu, select 

Cracks →Compute SIFs, Fig 2.39.  The Stress Intensity Factor dialog is displayed, Fig 2.40.  

You should use the M-integral, but you can check that the Displacement Correlation results are 

similar.  Select Finish and the SIFs Plot window is displayed, Fig 2.41.  You can view the three 

modes of stress intensity factors (SIFs) using the upper tabs:  KI, KII and KIII; mode II and III 

values should be negligible compared to mode I.  
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Figure 2.39  Compute SIFs selected from the Cracks menu. 

 

 

Figure 2.40  Compute SIFs dialog. 

 

 

The units for SIFs are MPa√mm.  The SIFs are plotted versus the normalized crack front length, 

starting from point A – see the image in the left pane of Fig 2.41. 
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Figure 2.41  Stress Intensity Factor display 

 

 

2.7  Step 7:  Manual Crack Growth 

 

We will “manually” propagate the crack front; this lets us examine the predicted crack growth to 

determine suitable parameters for fitting and extrapolation before proceeding with automated 

crack growth, which is described in Section 2.8. 

 

Step 7.1: Select Grow Crack 

 

From the FRANC3D menu, select Cracks →Grow Crack, Fig 2.42.  In the first panel, Fig 2.43, 

switch to Quasi-Static crack growth and select Next.  Use the Max Tensile Stress theory to 

determine the kink angle, Fig 2.44; in this model, crack growth is essentially planar.  Select 

Next.  Use a Power Law relationship to determine relative growth among points along the crack 

front, Fig 2.45; we will use the default power n=2.  There is only one load step in the model.  

Select Finish to proceed.  You will be asked if you want to save the growth parameters to a file, 

Fig 2.46, you can select No. 
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Consult the Reference document for descriptions of crack extension models. 

 

 

Figure 2.42  Grow Crack menu option. 

 

 

 

 

Figure 2.43  Crack Growth wizard – first panel. 
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Figure 2.44  Crack Growth wizard – second panel using quasi-static growth. 

 

 

 

Figure 2.45  Crack Growth wizard – third panel using quasi-static growth. 
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Figure 2.46  Save growth parameters dialog. 

 

 

Step 7.2: Specify Fitting and Extrapolation 

 

The next panel, Fig 2.47, allows you to specify the crack front point fitting parameters. You can 

double click on the (crack) view to see the crack surface; it should be the default view.   

 

The median extension is set to 0.15; this value usually is set automatically based on the initial 

template radius, so your value might be different.  We change it to 0.12 and turn on Mesh and 

Markers (top right checkbox in Fig 2.47).  The green boxes are the computed new front points, 

and the blue line is the curve-fit, Fig 2.48.  Note that the scale node is 0.5; the computed 

extensions are sorted from minimum to maximum, and the scale node can vary from 0 to 1. For a 

scale node of 0.5, the median extension is set to the user-specified value and all other extensions 

are scaled accordingly. 

 

A Fixed Order Polynomial fit with order set to 3 and extrapolation set to 2% at both ends of the 

crack front is the default; the fitting parameters might need to be adjusted as the crack grows.  A 

4th order polynomial might provide a slightly better fit in this case; the guideline for curve-fitting 

is to use the simplest fit that is reasonable.  We stick with the default 3rd order polynomial; select 

Next to proceed. 

 

Note that the fitted (blue) curve must be extrapolated so that both ends fall outside of the model, 

but it should not be extrapolated too much.  Normally FRANC3D will automatically find 

reasonable values for extrapolation. 
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The median extension must be enough to provide finite space between the current and new fronts 

along the entire front to define new crack geometry. 

 

 

Figure 2.47  Crack growth wizard panel for crack front fitting options 

 

 

Figure 2.48  Curve fit (blue) through front (green) points.  
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Step 7.3: Specify Crack Front Template 

 

The final panel, Fig 2.49, allows you to specify the crack front mesh template parameters. The 

crack front mesh template extends beyond the model surface, which corresponds with the front-

fit extrapolation.  The template radius can be set as an absolute value or as a % of the median 

extension.  A relative value of 85% is shown in Fig 2.49; we switch to an absolute value of 0.1, 

Fig 2.50, which is the same as the initial crack template radius.  Select Next on this panel when 

ready to proceed with crack insertion and remeshing. 

 

Note that the crack geometry for the extended crack is inserted into the original uncracked 

model, so do not overwrite, or remove the original uncracked model files. 

 

 

Figure 2.49  Crack growth wizard panel for mesh template options 
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A template radius that is slightly less than the crack extension usually works best, especially for 

cases where there is kinking or turning of the crack front.   

 

Figure 2.50  Template radius set to 0.1. 

 

 

The resulting model can be analyzed as was done for the initial crack (see Step 5 above).  Note 

that you will want to give this model a different name, such as Abaqus_Cube_ step_001, so that 

you do not overwrite the initial crack files.  You could continue with manual steps of growth 

followed by static analysis, or you can try automated crack growth, which is described next. 

 

 

2.8 Step 8:  Automatic Crack Growth 

 

This section describes the steps for automatic crack growth starting from the initial crack model.  

We start with an existing FRANC3D model, using the model created in Sections 2.4 and 2.5.  In 

most cases, we would simply do automatic growth after the manual step described in Section 2.7, 

but this will not show all the dialogs, so we will start from the initial crack model. 

 

Step 8.1: Open FRANC3D Restart File 

 

Start with the FRANC3D graphical user interface (see Fig 1.1) and select File →Open. Select 

the file name specified in Section 2.5, called Abaqus_Cube_Subdivide.fdb.  Select Accept.  The 
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model will be read into FRANC3D (along with the results files that were created when running 

the static analysis).  We will ignore the fact that we already propagated the initial crack in the 

previous step (but we will use the settings).  The next section describes the steps for automatic 

crack growth analysis. 

 

Step 8.2: Select Crack Growth Analysis 

 

From the FRANC3D menu, select Analysis →Crack Growth Analysis, Fig 2.51.  The first 

panel of the wizard, Fig 2.52, allows you to choose the method for computing SIFs.  We use the 

default selection of M-integral.  Select Next.  If this panel does not show up, the SIF method is 

chosen automatically based on your earlier choice when plotting SIFs. 

 

 

 

Figure 2.51  Crack Growth Analysis menu 
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Figure 2.52  Crack Growth Analysis wizard – first panel. 

 

 

Step 8.3: Specify Growth Rules 

 

The second panel, Fig 2.53, lets us set the crack growth type; we use quasi-static growth.  Select 

Next to display the third panel, Fig 2.54; use the default MTS theory to compute the kink angle.  

Select Next to display the fourth panel, Fig 2.55; use the default settings for the quasi-static 

growth; there is only one FEM load step to select.  Select Finish.  You will be asked if you want 

to save the growth parameters to a file; you can select No. 

 

 

 

Figure 2.53  Crack Growth Analysis wizard – second panel. 
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Figure 2.54  Crack Growth Analysis wizard – third panel. 

 

 

 

Figure 2.55  Crack Growth Analysis wizard – fourth panel. 
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Step 8.4: Specify Fitting and Template Parameters 

 

The fifth panel, Fig 2.56, lets us set the crack front fitting and mesh template parameters.  Use 

the default 3rd order polynomial and 2% extrapolation.  Set the template radius to an absolute 

value of 0.1.  Select Next. 

 

 

Figure 2.56  Crack Growth Analysis wizard – fifth panel. 

 

Step 8.5: Specify Growth Plan 

 

The sixth panel, Fig 2.57, lets us define the amount of extension for each step of crack growth.  

Set the number of steps to five and the constant median extension to 0.2. Select Next.  
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Note that we are taking a relatively large crack growth step; this is to limit the number of steps 

and time for this tutorial.  Large steps can sometimes lead to issues with oscillations in the shape 

of the crack fronts (see Section 9 of the User’s Guide), but for this model 0.2 is acceptable. 

 

 

Figure 2.57  Crack Growth Analysis wizard – sixth panel. 

 

 

Step 8.6: Specify Analysis Code 

 

The seventh panel, Fig 2.58, shows that ABAQUS is the solver.  The current crack growth step 

defaults to 0 – representing the initial crack.  (If we “manually” propagated the crack first, we 

should set this to 1.)  FRANC3D will extend the initial crack based on the growth rule defined in 

the previous panels, and then name the resulting set of files as 

Abaqus_Cube_Subdivide_STEP_001.*.  Subsequent file names have the step number 

incremented as the automatic analysis proceeds.  Select Next (button not shown in Fig 2.58). 
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Figure 2.58  Crack Growth Analysis wizard – seventh panel. 

 

 

The eighth panel, Fig 2.59, shows the analysis settings.  You should have already set the 

ABAQUS executable path in the FRANC3D Preferences.  The Global model settings should be 

set automatically.  The local + global connection is displayed in the next panel.  Select Next. 

 

 

 

Figure 2.59  Crack Growth Analysis wizard – eighth panel. 
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The ninth panel, Fig 2.60, displays the local + global connection.  The default settings use node-

merging of the cut-surfaces between the local and global portions.  Select Finish to start the 

automated crack growth process.  

 

 

Figure 2.60  Crack Growth Analysis wizard – ninth panel 

 

 

FRANC3D saves .fdb, .inp and other files for the first crack step model, using the name 

Abaqus_Cube_Subdivide_STEP_001, and then ABAQUS starts in the background.  If the 

analysis stops at any stage, it can be restarted from the last crack step.  All the required restart 

_STEP_# files are retained.  The model for any step can be read into FRANC3D to view the SIFs 

or to restart the analysis with a modified crack growth increment or modified fitting (for 

example).  

 

A summary of the various files can be found in Section 3 of the User’s Guide. 
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2.9 Step 9:  SIF History and Fatigue Life 

 

Once the automatic crack growth analysis from Step 8 has finished, the stress intensity factor 

history can be displayed.  If you still have FRANC3D open and the crack growth from Step 8 is 

done, you can proceed with Step 9.1.  Otherwise, you can restart FRANC3D and read in the .fdb 

file for the last step, using the File → Open menu option. 

 

Step 9.1: Select SIFs Along a Path 

 

From the FRANC3D menu, select Cracks →SIFs Along a Path, Fig 2.61.  If the SIFs have not 

been computed yet, the Compute SIFs dialog (see Fig 2.52) will be displayed; leave the defaults 

and select Finish. 

 

 

Figure 2.61  SIFs Along a Path menu option 
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The Stress Intensity Factors (along a path) dialog should appear, Fig 2.62.  The crack fronts are 

displayed on the left along with the path through the fronts; the SIF history along the path is 

shown in the graph on the right.  You can use the tabs above the graph to plot the Mode II and III 

SIFs as well as the elastic J-integral and T-stress values along the path.  You can define a new 

path, Fig 2.63.  You can export the data also; for example, you might need to export the Mode I 

SIF history (K vs a) to compute fatigue cycles using a different program.  The exported data files 

are ASCII txt files. 

 

 

 

Figure 2.62  SIFs Along a Path dialog – KI plot 

 

 

Step 9.2: Select SIFs For All Fronts 

 

From the FRANC3D menu, select Cracks →SIFs For All Fronts.  If the SIFs have not been 

computed yet, the Compute SIFs dialog will be displayed; leave the defaults and select Finish. 
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Figure 2.63  SIFs Along a Path dialog – Define Path 

 

The Stress Intensity Factors (for all fronts) dialog should appear, Fig 2.64.  The crack fronts are 

displayed on the left, and the SIFs for all crack fronts are displayed on the right.  You can use the 

tabs above the plot to display Mode II and III SIFs as well as the elastic J-integral and T-stress 

values.  If there are multiple crack fronts or multiple load steps, these can be selected using the 

drop-down lists; this will be seen in subsequent tutorials. 

 

 

Figure 2.64  SIFs for all Fronts dialog – KI plot 
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Step 9.3: Select Fatigue Life Predictions 

 

Fatigue life or cycles can be computed next.  From the FRANC3D menu, select Fatigue 

→Fatigue Life Predictions, Fig 2.65.  If the SIFs have not been computed yet, the Compute 

SIFs dialog will be displayed; leave the defaults and select Finish. 

 

 

Figure 2.65  Fatigue Life Predictions menu option 

 

 

The Fatigue Life dialog should appear as in Fig 2.66.  The crack fronts are displayed on the left 

and the window on the right side should be blank (assuming that lifing parameters have not been 

defined previously).  You must Set (or Read) Parameters.  Selecting Set Parameters displays 

the dialog shown in Fig 2.67. 
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The units are MPa and mm; select the Change button to display the dialog in Fig 2.68 and set the 

units to MPa and mm; select Accept. 

 

 

Figure 2.66  Fatigue Life dialog 

 

 

Figure 2.67  Fatigue Life parameters 
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The FEM units can also be set in the main FRANC3D window using the Edit menu.  

 

 

Figure 2.68  FEM units dialog 

 

 

The crack growth load schedule is defined next.  Select the New Schedule button (see Fig 2.67) 

to display the dialog in Fig 2.69.  Select the Schedule and then select the Add button; see right 

side image of Fig 2.69.  This will display the dialog shown in Fig 2.70; we use a simple cyclic 

load schedule where the applied load produces Kmax, and Kmin is zero. Select Accept to return 

to the Load Schedule, Fig 2.71.   

 

The stress ratio is set to 0.0.  There is only one load case, which represents the Kmax condition.  

The Repeat count is set to FOREVER.  Select Accept to finish the load schedule. There is only 

one event in the schedule so the repeat forever can be set for either the event or the schedule. 
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Figure 2.69  New Load Schedule dialog 

 

 

 

Figure 2.70  Event type dialog 
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Figure 2.71  Simple cyclic load schedule repeated forever 

 

 

The crack growth rate model is defined next.  Select the New Model button (see Fig 2.67) to 

display the dialog in Fig 2.72.  Choose the cyclic loading growth rate model, and select Next to 

display the dialog in Fig 2.73. 

 

 

Figure 2.72  Growth model type dialog 
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Figure 2.73  Cyclic loading growth model dialog 

 

 

We use a Paris growth model, which is the default; select Next to display the dialog in Fig 2.74.  

The growth rate model will be temperature independent.  Select Next to display the Paris growth 

model dialog, Fig 2.75. 

 

 

Figure 2.74  Temperature dependent or independent growth rate model dialog 
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Figure 2.75  Paris growth rate model dialog 

 

First, set the units for the Paris growth model.  Select the Change button to display the Units 

dialog, Fig 2.76.  Set the units the same as the FEM units that we set earlier, which were MPa 

and mm. If your growth model units are different from the FEM units, FRANC3D will do the 

unit conversions automatically.  Select Accept. 

 

 

Figure 2.76  Paris growth rate model units 
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In the Paris growth model dialog, click on the fields for C, n, DKth and Kc and enter the values 

shown in Fig 2.77. Select Next to return to the main dialog (see Fig 2.67). Other options are left 

at their default values; select Accept to return to the Fatigue Life dialog, Fig 2.78.  

 

 

Figure 2.77  Paris growth rate model values 

 

 

Figure 2.78  Fatigue life dialog showing Cycles vs Crack Growth Step 
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Note that the Paris exponent ‘n’ is set to 3 whereas we used n=2 for the quasi-static growth. In 

practice, you can use the fatigue model and material data during the growth, so that growth is 

consistent with the fatigue life computations done here.  However, it is not strictly necessary as 

fatigue cycles are recomputed here. 

 

If we choose to plot cycles based on a path, we must select the Path radio button and then the 

Define button to create a path, Fig 2.79.  The default path is through the crack front midpoints.  

Once a path is defined, the cycles versus crack path length is displayed, Fig 2.80. 

 

 

Figure 2.79  Define crack path dialog 

 

 

Figure 2.80  Fatigue cycles versus crack length 
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2.10 Step 10:  Resume Growth with Larger Submodel  

 

We used a local submodel for the crack growth simulation.  If the crack growth exceeds the 

boundary of the local submodel, a larger submodel can be selected and crack growth can be 

continued without having to restart the simulation from the beginning.  In this step, we describe 

the process of extracting the current crack geometry and inserting this crack into a larger portion 

of the model to resume crack growth.   

 

Step 10.1:  Extract and Save Crack Geometry 

 

The crack geometry information for each step of crack growth is saved in the FRANC3D restart 

(.fdb) file.  The data appears in this block: 

 

FLAWSURF 
( 
VERSION: 5 
NUM_SURFS: 763 
SURF: 0 
    263 264 356 
          6.83559456365193       5.00380971299962       9.72712346638146 
… 
… 
          4.73891556707121       5.00420103803897        8.3468309877949 
) 

 

This data can be copied from the .fdb file and saved to a .crk file, using any text editor.  

 

We open the Abaqus_Cube_subdivide_STEP_005.fdb file, copy the FLAWSURF data, and save 

it to a .crk file, called Abaqus_Cube _step_5.crk.   

 

At step 5, the crack is approaching the boundary of the submodel region, Fig 2.81, so we could 

not have grown the crack much further. 
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Figure 2.81 Crack step 5 in local submodel. 

 

 

Step 10.2:  Restart from Saved Crack Geometry 

 

Start FRANC3D, and from the menu select File →Import.  We could extract a larger submodel 

region from the cube, but for this tutorial, we will just import the full cube model and run 

subsequent crack growth simulations using the full model.   

 

Select Import a complete model from the dialog, Fig 2.82, set the Mesh File Type to ABAQUS, 

and select the Abaqus_Cube.inp file, Fig 2.83.  Select Accept to continue. 
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Figure 2.82 FRANC3D model import dialog. 

 

 

 

Figure 2.83 FRANC3D mesh import file selector. 

 

 

Note: if you choose to create a larger local submodel instead of using the full model, make sure 

you edit the local and global file names so that you do not overwrite the first set of local and 

global model files (see the dialog in Fig 2.17).  

 

 

Use the Select All button in the next dialog, Fig 2.84, to retain all the mesh facets where 

boundary conditions are applied.  Select FINISH when ready; the model will be imported and 

displayed in the FRANC3D main window (see Fig 2.9). You will need to set/accept the units as 

well as the work directory. 
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Figure 2.84 Use Select All button to retain all highlighted mesh facets. 

 

 

From the FRANC3D menu, select Cracks and Flaw From Files.  Select the 

Abaqus_Cube_step_5.crk file, which was extracted from the .fdb file. The .crk file is read and 

then displayed in the Orient User Flaw dialog, Fig 2.85.  Note that the crack geometry includes 

the original circular crack and all the subsequent steps of growth.  Also note that part of the crack 

geometry falls outside the model (so that intersections can be computed correctly).  In general, a 

crack that is read from a file can be translated in Cartesian space, but for continuing crack 

growth, we want the exact same location. 

 

Select Next to set the mesh template parameters, Fig 2.86; we just use the defaults.  Select 

Finish when ready, and the crack will be inserted and the model remeshed.  
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Figure 2.85 Step 5 crack geometry displayed in cube model. 

 

 

Figure 2.86 Step 5 crack mesh template. 

 

 

From the FRANC3D menu, select Static Crack Analysis and set the analysis parameters; use 

the same settings as in Step 5.  The only thing that has changed is the file name so that we do not 

overwrite the original submodel step files; call it Abaqus_cube_full_STEP_005. 
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The analysis should produce SIFs that are almost identical to the SIFs computed for the step_005 

using the local submodel region.  Fig 2.87 shows the Mode I SIFs for the two cases.  There are 

minor differences as the mesh around the crack front is different.  At this stage, the crack can be 

propagated further; do another six steps of crack growth using the same growth increment of 0.2.   

 

 

 

Figure 2.87 Step 5 Mode I SIFs for the original submodel analysis (top) compared with the new 

results using the full model (bottom). 
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After propagating the crack an additional six steps, we can combine the SIF history for the two 

analyses.  We do this in the next step using the Advanced menu option Create Growth History.  

 

Step 10.3:  Combine SIF Histories 

 

Start FRANC3D, select the File →Open menu option, and select the 

Abaqus_Cube_sub_STEP_005.fdb file.  From the Advanced menu, select Create Growth 

History, Fig 2.88.  The dialog shown in Fig 2.89 is displayed.  Note that the initial crack is 

labeled as CrackStep_1 and then there are five steps of growth after that.  You can use the Plot 

menu command to display the crack fronts, Fig 2.90. 

 

 

 

Figure 2.88 FRANC3D Advanced menu. 

 

 

Using the File menu in the Create Growth History dialog, select Save History, Fig 2.91, and 

save the SIF history to a .fcg file, called Abaqus_Cube_sub_steps.fcg here.  Close the dialog 

using the Cancel button, and then close the model in FRANC3D using File →Close.   
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Figure 2.89 Create Growth History dialog – submodel data. 

  

 

 

Figure 2.90 Create Growth History dialog. 
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Figure 2.91 Create Growth History dialog File menu. 

 

 

Now open the Abaqus_Cube_full_STEP_011.fdb file (our last step of crack growth) using File 

→Open.  As with the submodel, save the history using the Create Growth History dialog.  The 

SIF history for the full model is shown in Fig 2.92.  Note that CrackStep_1 in the full model 

gives the same SIFs as CrackStep_6 in the submodel; however, CrackStep_1 in the full model 

includes crack extension data.  

  

 

  

Figure 2.92 Create Growth History dialog – full model data. 
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Save the full model SIF history to a .fcg file, called Abaqus_Cube_full_steps.fcg.  Close the 

Create Growth History dialog and close the model.  This leaves the FRANC3D main model 

window empty.  Select the Advanced and Create Growth History menu option to display the 

dialog.  It does not have any CrackGrowthData. 

 

Use the File menu in the Create Growth History dialog and select Read History, Fig 2.93.  

Select the Abaqus_Cube_sub_steps.fcg file.  Then using the same menu, select Append History 

and select the Abaqus_Cube_full_steps.fcg file.  Note that there will be twelve steps of crack data 

at this stage, Fig 2.94.  We need to delete CrackStep_6 from the Submodel data as it does not 

include extension data.  We highlight CrackStep_6, and then right-click the mouse to display the 

submenu, Fig 2.95.  Select Delete Crack Step and it will be removed, leaving eleven crack 

steps.  You can plot the combined fronts, Fig 2.96. 

 

 

Figure 2.93 Create Growth History dialog – File menu. 

 

 

Figure 2.94  Create Growth History dialog – combined SIF history data. 
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Figure 2.95  Right-mouse button click on the CrackStep_6 to delete. 

 

 

Figure 2.96  Create Growth History dialog – combined crack fronts. 

 

 

Use the File menu in this dialog (see Fig 2.94) to save the combined SIF history to a .fcg file, 

called Abaqus_Cube_combined_steps.fcg.  The dialog can be closed by selecting the Cancel 

button at the bottom; selecting the Save button prompts you save the history data to file.  

 

The combined SIF history data can be imported into the Fatigue Life module using the Read SIF 

Data button, Fig 2.97.  Once you have Set Parameters, you can plot cycles; see Step 9.3. 
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Figure 2.97  Fatigue Life dialog. 
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Appendix A:   

ABAQUS local model between *Tie constraints 

 

This appendix describes how one can use an already-divided ABAQUS model, where the local 

portion is tied to the global portion using *TIE constraints.  Rather than dividing the model using 

the FRANC3D submodeling tools, one can divide the model and save the “local” and “global” 

.inp files using ABAQUS CAE.  This appendix describes ABAQUS specific features that are not 

fully described in the Tutorials 2-14 document. 

 

The complete model of a simple hinge is shown in Fig A-1. The local portion that will be 

imported into FRANC3D is located between two *TIE surfaces.  The complete model can be 

copied to a local and a global model and the appropriate portions of the model saved as separate 

.inp files.  In this example, the files are named: hinge-global.inp and hinge-local.inp.   Once 

these two files are saved, we can proceed to FRANC3D.  

 

 

Figure A-1  ABAQUS hinge model; local portion is contained between two *TIE surfaces. 
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From the FRANC3D File menu, select Import.  From the first dialog, Fig A-2, select the Import 

an already divided model option and click Next.  The second dialog, Fig A-3, allows one to 

choose the global and local .inp files.  Make sure the ABAQUS Mesh File Type is selected and 

then use the Browse button to specify the two files.  Once the hinge-global and hinge-local.inp 

files are selected, click Next.   

 

 

Figure A-2  Select type of import dialog. 

 

 

Figure A-3 Specify .inp files dialog for an already-divided model. 

 

 

The next dialog, Fig A4, allows one to retain mesh facets.  There are no boundary conditions, but 

we will retain the *TIE surfaces.  Click on the Show Surfaces button and check the tie-local 

surface.  Note that the tie-local surface was defined in ABAQUS CAE and is part of the local 
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portion.  There is a corresponding tie-global surface for the global portion.  Click Next to set the 

units (default units can be used), and then click Finish to proceed to the FRANC3D main 

window, where the model will be displayed, Fig A-5. 

 

 

Figure A-4  Select retained surfaces dialog; the *TIE constraint surfaces are selected. 

 

 

Figure A-5  FRANC3D local model imported with the *TIE surface mesh retained. 
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The next step is to define and insert a crack.  We have defined and saved a crack to a file 

previously, so we use the Cracks menu and choose Flaws from Files.  Fig A-6 shows the dialog 

box that allows us to choose the hinge.crk file.  Once the file is selected, click Accept.  

 

Fig A-7 shows the crack location in the local portion; we can move it if needed.  The crack is a 

center-through type crack with two crack fronts; the distance between the two fronts is 2 units.  

  

Click Next to set the crack front template mesh settings, Fig A-8.  The template radius is saved 

in the .crk file as 0.1; we leave all the settings at their default values and click Finish to insert the 

crack and remesh.  The remeshed local cracked model is shown in Fig A-9. 

 

 

 

Figure A-6.  Dialog to choose the .crk file. 
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Figure A-7.  Crack location dialog. 

 

 

 

Figure A-8. Crack front template mesh settings dialog. 
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Figure A-9.  Remeshed cracked local portion. 

 

Once the crack is inserted, we can perform a static analysis.  From the Analysis menu, select 

Static Crack Analysis.  The first dialog, Fig A-10, allows us to specify the file name.  We call it 

hinge_crack.  Click Next and check that the solver is ABAQUS, Fig A-11.  Click Next to set the 

ABAQUS solver options and to specify the global file name, Fig A-12. 

 

 

Figure A-10.  Static analysis file name dialog. 
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Figure A-11.  Specify the solver as ABAQUS. 

 

 

Figure A-12.  Specify the ABAQUS analysis options. 
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The Global model file name is already filled in by default based on the imported file selection.  

Click Next to advance to the next dialog, Fig A-13, where we specify how the local and global 

model portions will be re-connected.  The “tie-local” and “tie-global” surfaces must be selected 

along with the Tie constraint option.   

 

Click Finish to start the process of saving the analysis files and running ABAQUS in the 

background.  Once ABAQUS finishes running, we can compute the SIFs and analyze the results 

to verify that FRANC3D correctly processed all the ABAQUS information. 

 

 

Figure A-13.  Specify the ABAQUS local + global model connection. 

 

 

ABAQUS creates a .dtp file and this file is automatically imported into FRANC3D (assuming 

that you are running ABAQUS on the same PC).  Use the Cracks menu and select Compute 

SIFs, Fig A-14.  Click Finish to display the SIFs for the two crack fronts, Fig A-15. 
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Figure A-14.  Compute SIFs dialog. 

 

 

Figure A-15.  Display SIFs dialog. 

 

The SIFs indicate that the hinge is bending, which is what we expect.  The deformed shape for 

the uncracked hinge is shown in Fig A-16.  The contours show the displacement magnitude.  Fig 

A-17 shows the same displacement magnitude contours for the cracked hinge model.  The 

contours are almost identical, indicating that the cracked model is valid.  Fig A-18 shows a close-

up of the crack mouth; the displacement scaling is 10x and the contours show the maximum 

principal stress.  
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Figure A-16.  Displacement magnitude contours for the uncracked hinge. 

 

 

Figure A-17.  Displacement magnitude contours for the cracked hinge. 
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Figure A-18.  Maximum principal stress contours for the cracked hinge. 

 

 

Under these conditions, crack growth only occurs where the Mode I SIF is positive, Fig A-19.  

 

 

Figure A-19.  Crack front partial growth. 
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Appendix B:  

ABAQUS model with *Tied solid and shell 

 

This appendix describes how one can simulate crack growth in models with mixed solid and 

shell elements using *Tie constraints.  A simple cube volume mesh with a shell surface attached 

is shown in Fig B-1.  The cube mesh has two components, one for the region with the coarse 

mesh and one for the small portion with the more refined mesh.  The two components are 

connected by *Tie constraints, as the meshes on the two adjacent surfaces do not match. 

 

 

Figure B-1  ABAQUS model with mixed meshes and *Tie constraints. 

 

From the FRANC3D File menu, select Import.  In the first dialog, the “import and divide” option 

is the default, so just click Next.  Select the .inp file and click Accept to display the dialog 

shown in Fig B-2.  The shell elements will be displayed but cannot be selected; these elements 

will be part of the global .inp file.  The local model should be selected so that the *Tie surface 

between the mismatched mesh surfaces stays with the global portion also.  Fig B-2 shows the 

local portion highlighted; note that a layer of elements from the refined mesh adjacent to the Tie 

surface is not selected. 
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Figure B-2  ABAQUS model with local FRANC3D portion highlighted. 

 

The local portion will be displayed in the subsequent dialog, Fig B-3.  AUTO_CUT_SURF is 

created by FRANC3D to define the cut-surface.  The mesh facets for this will be retained by 

default.  Click Next and set the units, and the click Finish to proceed to the main FRANC3D 

window; the resulting local model should appear as in Fig B-4. 

 

A surface elliptical crack is defined and inserted into the local model, Fig B-5.  Once this crack is 

inserted and remeshing is completed, the model can be analyzed.   The local portion is 

reconnected with the global portion.  We left the existing *Tie surface between the mismatched 

meshes in the global portion.  The original mesh was composed of linear brick elements and the 

remeshed crack portion consists of quadratic elements (bricks, wedges, pyramids and tetrahedra). 

So, the local cracked portion is connected to the global using additional *Tie constraints, Fig B-

6.  AUTO_CUT_SURF and GLOBAL_CONNECT_SURF are defined by FRANC3D, and these 

are selected automatically along with the *Tie radio button.  Select Finish to run the analysis. 
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Figure B-3  Local model portion. 

 

 

Figure B-4  Local model with retained mesh facets on the cut-surface. 
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Figure B-5  Elliptical surface crack inserted into the local model. 

 

 

Figure B-6  Local + global model connection. 
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The resulting Mode I SIFs for the crack are shown in Fig B-7.  The displacement magnitude 

contours for the original uncracked and the cracked model are shown in Fig B-8 and Fig B-9.  

The results match well; the results might be improved by using quadratic elements in the original 

model. 

 

 

Figure B-7  Initial crack Mode I SIFs. 

 

 

Figure B-8  Uncracked model displacement contours. 
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Figure B-9  Cracked model displacement contours. 
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Appendix C:  ABAQUS Keywords  

 

The list of ABAQUS keywords that FRANC3D recognizes is provided here.  FRANC3D must 

process some of the data, but a large amount of the .inp file can be passed through to the 

_GLOBAL.inp and then to the _full.inp, which is the combination of the cracked/remeshed 

portion of the model and the _GLOBAL.inp portion. 

 

static const char* reserved[] = { 

    "*AMPLITUDE", 

    "*ASSEMBLY", 

    "*BEAM SECTION", 

    "*BEAM GENERAL SECTION", 

    "*BOUNDARY", 

    "*CLEARANCE", 

    "*CLOAD", 

    "*CONDUCTIVITY", 

    "*CONTACT PROPERTY ASSIGNMENT", 

    "*CONTACT INCLUSIONS", 

    "*CONTACT CONTROLS", 

    "*CONTACT PAIR", 

    "*CONTACT OUTPUT", 

    "*CONTACT", 

    "*CONTOUR INTEGRAL", 

    "*CONTROLS", 

    "*COUPLED THERMAL-ELECTRICAL", 

    "*COUPLING", 

    "*CYCLIC HARDENING", 

    "*CYCLIC SYMMETRY MODEL", 

    "*CYCLIC", 

    "*DAMAGE EVOLUTION", 

    "*DAMAGE INITIATION", 

    "*DAMAGE STABILIZATION", 

    "*DENSITY", 

    "*DEPVAR", 

    "*DLOAD", 

    "*DSECURRENT", 

    "*DSLOAD", 

    "*EL FILE", 

    "*EL PRINT", 

    "*ELASTIC", 

    "*ELECTRICAL CONDUCTIVITY", 

    "*ELEMENT", 

    "*ELEMENT OUTPUT", 

    "*ELSET", 

    "*END ASSEMBLY", 

    "*END INSTANCE", 

    "*END LOAD CASE", 

    "*END PART", 

    "*END STEP", 
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    "*ENDSTEP", 

    "*END", 

    "*EQUATION", 

    "*EXPANSION", 

    "*FIELD", 

    "*FILE FORMAT", 

    "*FREQUENCY", 

    "*FRICTION", 

    "*GLOBAL DAMPING", 

    "*HEADING", 

    "*HYPERELASTIC", 

    "*HYPOELASTIC", 

    "*INCLUDE", 

    "*INITIAL CONDITIONS", 

    "*INITIAL CONDITION", 

    "*INITIAL COND", 

    "*INSTANCE", 

    "*KINEMATIC COUPLING", 

    "*LOAD CASE", 

    "*MASS", 

    "*MATERIAL", 

    "*MODAL DYNAMIC", 

    "*MODAL OUTPUT", 

    "*MODEL CHANGE", 

    "*MPC", 

    "*NCOPY", 

    "*NODE", 

    "*NODE FILE", 

    "*NODE PRINT", 

    "*NORMAL", 

    "*NSET", 

    "*ORIENTATION", 

    "*OUTPUT", 

    "*PART", 

    "*PLASTIC", 

    "*POROUS BULK MODULI", 

    "*POROUS ELASTIC", 

    "*POROUS FAILURE CRITERIA", 

    "*POROUS METAL PLASTICITY", 

    "*PRE-TENSION SECTION", 

    "*PREPRINT", 

    "*RESTART", 

    "*RIGID BODY", 

    "*ROTARY INERTIA", 

    "*SELECT EIGENMODES", 

    "*SHEAR FAILURE", 

    "*SOLID SECTION", 

    "*SPECIFIC HEAT", 

    "*SPRING", 

    "*STEP", 

    "*SUBMODEL", 

    "*SURFACE BEHAVIOR", 

    "*SURFACE INTERACTION", 

    "*SURFACE", 

    "*SYSTEM", 
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    "*TEMPERATURE", 

    "*TIE", 

    "*TRANSFORM", 

    "*USER MATERIAL", 

    "ABSOLUTE EXTERIOR TOLERANCE", 

    "ADJUST", 

    "AMPLITUDE", 

    "BINC", 

    "BSTEP", 

    "CHANGE NUMBER", 

    "CONSTRAINT NAME", 

    "CONVERT SDI", 

    "CONTROLS", 

    "COORDINATES", 

    "CYCLIC SYMMETRY", 

    "CYLINDRICAL", 

    "DEFINITION", 

    "DISPLACEMENT", 

    "ELEMENT", 

    "ELSET", 

    "EXTERIOR TOLERANCE", 

    "FILE", 

    "FOLLOWER", 

    "GENERATE", 

    "INC", 

    "INPUT", 

    "INSTANCE", 

    "INTERPOLATE", 

    "ITERATIVE", 

    "MASTER", 

    "MATERIAL", 

    "MIDSIDE", 

    "MOD", 

    "NAME", 

    "NEW SET", 

    "NEW", 

    "NLGEOM", 

    "NO", 

    "NODE", 

    "NSET", 

    "OLD SET", 

    "OP", 

    "ORIENTATION", 

    "PART", 

    "PERTURBATION", 

    "PIN SET", 

    "POSITION TOLERANCE", 

    "RAMP", 

    "REF NODE", 

    "SHIFT", 

    "SLAVE", 

    "SOLVER", 

    "SPHERICAL", 

    "SPRING", 

    "STEP", 
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    "STRESS", 

    "SUBMODEL", 

    "SURFACE", 

    "SYSTEM", 

    "TEMPERATURE", 

    "TIME", 

    "TYPE", 

    "UNSORTED", 

    "USER", 

    "VALUE", 

    "VARIABLE", 

    "VARIABLES", 

    "YES", 

    "Z RECTANGULAR", 

} ; 
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