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1.0 Introduction
This tutorial introduces the fracture simulation capabilities of FRANC3D Version 8 and ANSYS
2021 R2; other versions of ANSYS should work also. FRANC3D is introduced by analyzing a
single surface crack in an ANSYS finite element (FE) model of a cube.

Subsequent tutorials (see the FRANC3D Tutorials #2-14 document) build on this first example
and describe additional capabilities and features of the software. It is intended that the user
perform operations as they are presented, but you are free to experiment and consult the other
reference documentation whenever necessary.

FRANC3D menu and dialog button selections are indicated by bold text, such as File menu.
Window regions along with dialog options, fields and labels are underlined. Model names and
file names are indicated by italic text.

The FRANC3D main window is shown in Fig 1.1. When you start the tutorial, the first thing to
do is set the working directory using the File and Work Directory menu option, Fig 1.1.

Before or after a model is imported, you can set the FE model units, Fig 1.2. The selected units
are applied to plots and figures that FRANC3D might display and are used during crack growth
in combination with fatigue crack growth rate data, which also has units.

You can also set your preferences; it is helpful to set the path to the ANSYS executable. You
can view the preferences using the Edit and Preferences menu option. The Preferences dialog is
described in Section 5.4 of the FRANC3D Reference document.
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Figure 1.1 FRANC3D main window – Set Work Directory menu option.

Figure 1.2 FRANC3D FE model unit conversion menu option and dialog.
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2.0 Tutorial 1: Crack Insertion and Growth in a Cube
In this tutorial, a single surface crack in a cube under far-field tension is modeled. It is assumed
that the user is familiar with a pre-processor for ANSYS; we use ANSYS Mechanical APDL.
Once the FE model is created, the FRANC3D steps necessary to: 1) read the model, 2) insert a
crack, 3) perform the ANSYS analysis, and 4) compute stress intensity factors, are all described.

2.1

Step 1: Create the ANSYS FE Model

First, you must create a cube model using any pre-processor for ANSYS. We outline the steps to
create the FE model with boundary conditions to ensure that you have a model that can be used
with FRANC3D.

1. Create a 10x10x10 cube geometry; units of length are mm.
2. Subdivide the edges for meshing, using 10 to 20 subdivisions.
3. Define the element type as quadratic; use brick or tetrahedral elements to mesh the
volume.
4. Define the material properties; elastic modulus (E) is 10000 and Poisson’s ratio is 0.3;
units for E are MPa..
5. Boundary conditions consist of displacement constraints on the bottom surface and
uniform traction (a negative pressure) on the top surface. The bottom surface is
constrained in the y-direction, the bottom left edge is also constrained in the x-direction,
and the point at the origin is also constrained in the z-direction. The top surface traction
is 10 MPa.
6. Write the .cdb file (Ansys_Cube.cdb). When saving the .cdb file, you do not need to
write the IGES data. ANSYS Classic/APDL and ANSYS Workbench both allow you to
write .cdb files.

The resulting model should appear as in Fig 2.1. The symbols for the boundary conditions are
displayed attached to the mesh model.
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Figure 2.1 ANSYS cube with brick element mesh and boundary conditions.

2.2

Step 2: Reading ANSYS FE Model into FRANC3D

Once the ANSYS FE model is created and the .cdb file is saved, we can proceed with importing
the FE model into FRANC3D. We use the Ansys_Cube.cdb file that was created in the previous
step.

You can choose to do either this Step 2 or Step 3 (see Section 2.3).

Step 2.1: Importing Complete ANSYS FE Model

Start with the FRANC3D graphical user interface (see Fig 1.1) and select File and Import, Fig
2.2. In the dialog shown in Fig 2.3, choose Complete Model and select Next.
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Figure 2.2 File Import menu option

Figure 2.3 Model Import Type dialog

Switch the Mesh File Type radio button in the Select Import Mesh File window, Fig 2.4, to
ANSYS and select the file name for the model, Ansys_Cube.cdb, and then select Next.

Note that the mesh file type can be set in the Preferences so that you do not have to change the
mesh file type radio button if you always use ANSYS.
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Figure 2.4 Select Input Mesh File dialog box

Step 2.2: Select the Retained Items in the FE Model

The next panel, Fig 2.5, allows you to choose the mesh surface facets that are retained from the
ANSYS .cdb file. Surfaces with boundary conditions appear in blue as shown in Fig 2.6, and
turn red when selected, Fig 2.7. You can rotate the model to view all surfaces. We retain the
surfaces with boundary conditions (top and bottom of the cube) by choosing Select All. The
boundary conditions are transferred automatically to the new mesh when a crack is inserted.

Select Finish to proceed. The Units dialog will be displayed; if you have already set the units
using the Edit menu, just select Finish.
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Figure 2.5 Select Retained BC Surfaces wizard panel.

Figure 2.6 ANSYS Model retain BC Surfaces wizard panel - Unselected Surface
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Figure 2.7 ANSYS Model retain BC Surfaces wizard panel – Selected Surface

Surface Mesh NOT Retained

The surface mesh facets do not have to be retained, and if a crack will be inserted into a surface
that has boundary conditions, then the surface mesh must not be retained. In such a case, the
boundary condition data is mapped to the remeshed surface. In practice, transfer of boundary
condition data is simpler and more precise if the surface mesh is retained, but sometimes this is
not possible. FRANC3D will automatically transfer the boundary condition data to the new mesh
in either case.

Step 2.3: Displaying the FE Model

The model is displayed in the FRANC3D modeling window, Fig 2.8. You can turn on the
surface mesh, or manipulate the model view by rotating, etc. Fig 2.8 shows the retained mesh on
the top surface (retained bottom surface not visible) where the boundary conditions are applied.
See Section 2 of the Reference document for a description of the view manipulation.
11

Figure 2.8 ANSYS model imported into FRANC3D with retained facets on top of the cube.

If you have not set a working directory (using the File →Work Directory menu option),
FRANC3D might present the dialog shown in Fig 2.9 prior to displaying the model. Select Yes
to set the directory to be the folder where the ANSYS .cdb file resides. Many files are created
during a crack growth simulation, and it is best to keep them together in one folder.

Figure 2.9 Set Working Directory dialog.
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2.3

Step 3: Importing and Subdividing the Model

If you chose to do Step 2 above, either skip this step, or close the model using the File →Close
menu option before starting this step.

The ANSYS model can be split into smaller parts before inserting the crack. Go to File
→Import and choose the Import and divide into global and local models radio button, Fig 2.10,
and choose the Ansys_Cube.cdb model, Fig 2.11. Remember to set the Mesh File Type radio
button to ANSYS.

Figure 2.10 Model Import Type dialog with Import and divide selected

Instead of the retain BC surfaces dialog (see Fig 2.5), the Define a Local Submodel window, Fig
2.12, appears. Figs 2.13 and 2.14 show two of the submodel selection tools. Using the options
on the left, a submodel is selected; elements to be retained in the submodel appear red, and the
selection is confirmed using the Crop button. See Section 4.5 of the Reference document for a
more complete description of the submodeling tools.

For this tutorial, the rectangular Rubberband Box is used to create a smaller portion of the cube,
Fig 2.15, which has an exposed face for crack insertion.
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Figure 2.11 Select Input Mesh File selection.

Figure 2.12 Define a Local Submodel Window
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Figure 2.13 Plane Cutting tool – red elements will be retained by Crop

Figure 2.14 Element-by-Element cropping by selecting elements to remove

We are inserting a surface crack normal to the y-axis (loading direction) and located on the +z
surface, and the selection in Fig 2.15 is designed for this. Use the Rectangular option of the
Rubberband Box to select and Crop a small portion of the model.
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Figure 2.15 Rubberband Box tool used to select a submodel

Once the elements have been selected and cropped, select Next. The Save Files dialog appears,
Fig 2.16. Choose the names of the local and global models and their location; we use the default
file names and the working directory set earlier. Select Next.

Figure 2.16 Local/Global model save window
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If the local cropped model has a surface with boundary conditions, then the Select Retained BC
Surfaces window (see Fig 2.5) appears. Otherwise, the local model appears in the FRANC3D
main window, with retained surfaces wherever the local and global models connect (the cut
surfaces).

In this case, the cropped selection in Fig 2.15 avoids all surfaces with boundary conditions.
However, if there are ANSYS node components in the local model, then the Select Retained BC
Surfaces window might still be displayed; just select Next to proceed.

The model units, Fig 2.17, must be set. As defined in Step 1, the units for length are mm and the
units for stress are MPa. The temperature and time units are not needed for this tutorial.

Figure 2.17 FE Model units

Select Finish and the local model is displayed in the main FRANC3D window, Fig 2.18. The
cut-surface mesh facets are retained, while the front surface, where the crack will be inserted,
does not have retained facets.
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Figure 2.18 Local model with retained mesh facets on cut-surface

2.4

Step 4: Insert a Crack

We now insert a half-penny surface crack into the model. The local submodel from Section 2.3 is
used, as opposed to the full model from Section 2.2. In Step 4.1, we describe how to define a
new crack, and in Step 4.2, we describe how to insert a flaw from a file.

Note that you cannot insert a crack into a cracked model. If you want to try both types of crack
insertion, you will have to re-import the uncracked model to insert a crack from a file; inserting a
crack from a file will be used in subsequent steps and other tutorials.

Step 4.1: Define a new Crack from FRANC3D Menu
From the FRANC3D menu, select Cracks →New Flaw Wizard, Fig 2.19. The first panel of the
wizard, Fig 2.20, allows you to select the flaw type; a crack with zero volume is the default. We
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select the Save to file and add flaw radio button; the .crk file is saved for subsequent tutorials.
Select Next. The second panel, Fig 2.21, lets you choose the crack shape; the default is the
ellipse, which is what we want. Select Next.

Figure 2.19 New Flaw Wizard menu item selected.
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Figure 2.20 New Flaw Wizard first panel – Crack (zero volume flaw) selected.

Figure 2.21 New Flaw Wizard second panel – choose ellipse shape.
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The crack is a circle with radius=1, centered on the cube’s front (+z) face, and parallel to the xzplane (normal to y). The third wizard panel lets you set the dimensions for the ellipse, Fig 2.22;
set a=1 and b=1. Select Next.

Figure 2.22 New Flaw Wizard third panel – set ellipse dimensions.

The fourth panel lets you set the crack location and orientation, Fig 2.23. We place the crack at
the center of the front face at coordinates (5,5,10) and rotate the crack 90 degrees about the
Global x-axis. Select Next.

The final panel allows you to set the crack front mesh template parameters, Fig 2.24; use the
defaults. In practice, the default template radius is based on the crack dimensions and might
need to be adjusted depending on the model and crack. Select Finish.
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Figure 2.23 New Flaw Wizard fourth panel – set crack location and orientation.

Figure 2.24 New Flaw Wizard final panel – set template mesh parameters.

At this point, you are asked to specify the file name to save the crack information, Fig 2.25; we
call it Cube_Crack.crk. Select Accept.
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Figure 2.25 New Flaw Wizard final panel – save file as.

The crack is inserted into the model and then remeshing occurs. A Flaw Insertion Status window
is displayed during this process, Fig 2.26. There are four stages: geometric intersection of the
crack with the model, surface meshing, volume meshing, and smoothing of the volume mesh.
The resulting model is displayed in the main FRANC3D window, Fig 2.27; the surface mesh is
turned on in this image.

Figure 2.26 Flaw Insertion Status window.
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Figure 2.27 Remeshed cracked local model with surface mesh turned on.

Step 4.2: Insert Cracks from Files

If you want to try this step, you must Close the model from Step 4.1 and re-import the original
uncracked (local) model.
From the FRANC3D menu, select Cracks →Flaw From Files, Fig 2.28. The first panel, Fig
2.29, lets you select the .crk file. Choose the Cube_Crack.crk file name and select Accept. The
flaw being added is a circle with radius=1, centered on the cube’s front face, and parallel to the
xz-plane.

This crack was created using the New Flaw Wizard with the save to file option in Step 4.1.
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Figure 2.28 Flaw From Files option in Crack menu.

Figure 2.29 Flaw from file dialog to select .crk file.
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The next panel of the wizard, Fig 2.30, allows you to adjust the location of the flaw. The
orientation cannot be changed. The final panel, Fig 2.31, allows you to set the template mesh
parameters. Use the default settings and select Finish to complete the insertion and remeshing.

Figure 2.30 Flaw wizard panel to set location.

Figure 2.31 Flaw geometry shown in the model with crack template mesh
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2.5

Step 5: Static Crack Analysis

Once the crack is inserted and the model is remeshed, we perform a stress analysis using
ANSYS, which provides the displacement results that are needed to compute stress intensity
factors (SIFs). Typically, you would run a “static crack analysis” of the initial crack prior to
running automated crack growth; this allows you to verify that the crack model is consistent with
the uncracked model. You can compare displacement contours for the uncracked and cracked
models to verify that the crack model is valid.

You might also try to re-insert the crack with a bigger or smaller template radius to verify that
the computed SIFs are accurate; there should be no notable change in SIFs for a reasonable
template mesh.

Step 5.1: Select Static Crack Analysis
From the FRANC3D menu, select Analysis →Static Crack Analysis, Fig 2.32. The first panel,
Fig 2.33, requests that you enter the file name for the FRANC3D data. We call it
Ansys_Cube_Subdivide.fdb; select Next once you enter a File Name.

Note that you cannot use the initial uncracked Ansys_Cube.cdb or Ansys_Cube_LOCAL.cdb file
names, because a new .cdb file will be created during the analysis. The original uncracked .cdb
files are reused for each step of crack growth.
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Figure 2.32 Static Crack Analysis menu

Figure 2.33 Static Analysis wizard first panel – File Name
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Step 5.2: Select FE Solver

The next panel of the wizard, Fig 2.34, allows you to specify the solver; choose ANSYS and
select Next (button not shown in Fig 2.34). If this panel does not show up, the ANSYS solver
has been chosen automatically.

Figure 2.34 Static Analysis wizard second panel – choose solver

Step 5.3: Select ANSYS Analysis Options

The next panel of the wizard, Fig 2.35, allows you to specify the ANSYS output and analysis
options. The model is a sub-model and must be combined with the global model, so the Connect
to global model box is checked automatically if the FRANC3D submodeler tool was used. The
next panel, Fig 2.36, allows you to set the local + global model connection.

Note that if the model being analyzed is a full/complete model, the panel in Fig 2.35 is the final
panel as there is no global model, and the Next button will be a Finish button.

Fig 2.36 shows the options for joining the local and global models. AUTO_CUT_SURF and
GLOBAL_CONNECT_SURF are the sets/surfaces created by the FRANC3D submodeling tool
and should be selected automatically. Click Finish to start ANSYS running (in batch/background
mode). FRANC3D writes files and then attempts to execute ANSYS based on the ANSYS
Executable information (Fig 2.35). You can monitor the FRANC3D CMD window and the
ANSYS .err, .out and .log files for errors or messages.
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Figure 2.35 Static Analysis wizard third panel – ANSYS output options

Figure 2.36 Local/Global model connection
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Note that if ANSYS does not run, you will see a message in FRANC3D indicating that SIFs
cannot be computed because there are no displacements, or you might see a message indicating
that FRANC3D cannot find or open the .dtp file. This might be due to an incorrect path to the
ANSYS executable or an incorrect license string. The default ANSYS license string is “ansys”.
You can determine your ANSYS license string by using the Mechanical APDL Product
Launcher. Using the top menu bar of the Product Launcher, click on Tools – Display Command
Line, and then look for “-p“ in the window that is displayed; the license string will follow the -p.

Choosing Write files but DO NOT run analysis in Fig 2.36 will create all the files without
running ANSYS, if the analysis needs to be run later or on a different computer.

If you need to run analyses on a different computer, you must bring the results file (.dtp) back to
the working folder, and then you can use the File and Read Results menu option to import the
results into FRANC3D. The .dtp file is created by ANSYS APDL commands, which are part of
the .cdb file that FRANC3D writes.

2.6

Step 6: Compute Stress Intensity Factors

Step 6.1: Select Compute SIFs

Once the ANSYS analysis is done, we can compute SIFs. From the FRANC3D menu, select
Cracks →Compute SIFs, Fig 2.37. The Stress Intensity Factor dialog is displayed, Fig 2.38.
You should use the M-integral, but you can check that the Displacement Correlation results are
similar. Select Finish and the SIFs Plot window is displayed, Fig 2.39. You can view the three
modes of stress intensity factor (SIFs) modes using the upper tabs: KI, KII and KIII; mode II
and III values should be negligible compared to mode I.
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Figure 2.37 Compute SIFs selected from the Cracks menu

Figure 2.38 Compute SIF dialog

The units for SIFs are MPa√mm. The SIFs are plotted versus the normalized crack front length,
starting from point A – see the image in the left pane of Fig 2.39.
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Figure 2.39 Stress Intensity Factor plot

2.7

Step 7: Manual Crack Growth

We will “manually” propagate the crack front; this lets us examine the predicted crack growth to
determine suitable parameters for fitting and extrapolation before proceeding with automated
crack growth, which is described in Section 2.8.

Step 7.1: Select Grow Crack
From the FRANC3D menu, select Cracks →Grow Crack, Fig 2.40. In the first panel, Fig 2.41,
switch to Quasi-Static crack growth and select Next. Use the Max Tensile Stress theory to
determine the kink angle, Fig 2.42; in this model, crack growth is essentially planar. Select
Next. Use a Power Law relationship to determine relative growth among points along the crack
front, Fig 2.43; we will use the default power n=2. There is only one load step in the model.
Select Finish to proceed. You will be asked if you want to save the growth parameters to a file,
Fig 2.44, you can select No.
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Consult the Reference document for descriptions of crack extension models.

Figure 2.40 Grow Crack menu option.

Figure 2.41 Crack Growth wizard – first panel.
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Figure 2.42 Crack Growth wizard – second panel using quasi-static growth.

Figure 2.43 Crack Growth wizard – third panel using quasi-static growth.
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Figure 2.44 Save growth parameters dialog.

Step 7.3: Specify Fitting and Extrapolation

The next panel, Fig 2.45, allows you to specify the crack front point fitting parameters. You can
double click on the (crack) view to see the crack surface; it should be the default view.

The median extension is set to 0.15; this value is set automatically based on the initial template
radius so your value might be different. We change it to 0.12 and turn on Mesh and Markers
(top right checkbox in Fig 2.45). The green boxes are the computed new front points, and the
blue line is the curve-fit, Fig 2.46. Note that a scale node of 0.5 is the median; the extensions are
sorted from minimum to maximum, and the scale node varies from 0 to 1.

A Fixed Order Polynomial fit with order set to 3 and extrapolation set to 2-3% at both ends of
the crack front is the default; the fitting parameters might need to be adjusted as the crack grows.
A 4th order polynomial provides a slightly better fit in this case; the guidelines for curve-fitting
are to use the simplest fit that is reasonable. We stick with the default 3rd order polynomial;
select Next to proceed.

Note that the fitted (blue) curve must be extrapolated so that both ends fall outside of the model,
but it should not be extrapolated too much. Normally FRANC3D will automatically find
reasonable values for extrapolation.

The median extension must be enough to provide finite space between the current and new fronts
along the entire front to define new crack geometry.
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Figure 2.45 Crack growth wizard panel for crack front fitting options

Figure 2.46 Curve fit through front points.
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Step 7.4: Specify Crack Front Template

The final panel, Fig 2.47, allows you to specify the crack front mesh template parameters. The
crack front mesh template extends beyond the model surface, which corresponds with the frontfit extrapolation. The template radius can be set as an absolute value or as a % of the median
extension. The default is 85% as shown in Fig 2.47; we switch to an absolute value of 0.1, Fig
2.48, which is the same as the initial crack template radius. Select Next on this panel when
ready to proceed with crack insertion and remeshing.

Note that the crack geometry for the extended crack is inserted into the original uncracked
model, so do not overwrite or remove the original uncracked model files.

Figure 2.47 Crack growth wizard panel for mesh template options
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A template radius that is slightly less than the crack extension usually works best, especially for
cases where there is kinking or turning of the crack front.

Figure 2.48 Template radius set to 0.1

The resulting model can be analyzed as was done for the initial crack (see Step 5 above). Note
that you will want to give this model a different name, such as Ansys_Cube_ step_001, so that
you do not overwrite the initial crack files. You could continue with manual steps of growth
followed by static analysis, or you can try automated crack growth, which is described next.

2.8

Step 8: Automatic Crack Growth

This section describes the steps for automatic crack growth starting from the initial crack model.
We start with an existing FRANC3D model, using the model created in Section 2.4 and 2.5. In
most cases, we would simply do automatic growth after the manual step described in Section 2.7,
but this will not show all the dialogs, so we will start from the initial crack model.

Step 8.1: Open FRANC3D Restart File
Start with the FRANC3D graphical user interface (see Fig 1.1) and select File →Open. Select
the file name specified in Section 2.5, called Ansys_Cube_Subdivide.fdb. Select Accept. The
39

model will be read into FRANC3D (along with the results files that were created when running
the static analysis). We will ignore the fact that we already propagated the initial crack in the
previous step (but we will use the settings). The next section describes the steps for automatic
crack growth analysis.

Step 8.2: Select Crack Growth Analysis
From the FRANC3D menu, select Analysis →Crack Growth Analysis, Fig 2.49. The first
panel of the wizard, Fig 2.50, allows you to choose the method for computing SIFs. We use the
default selection of M-integral. Select Next. If this panel does not show up, the SIF method is
chosen automatically based on your earlier choice when plotting SIFs.

Figure 2.49 Crack Growth Analysis menu
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Figure 2.50 Crack Growth Analysis wizard – first panel.

Step 8.3: Specify Growth Rules

The second panel, Fig 2.51, lets us set the crack growth type; we use quasi-static growth. Select
Next to display the third panel, Fig 2.52; use the default MTS theory to compute the kink angle.
Select Next to display the fourth panel, Fig 2.53; use the default settings for the quasi-static
growth. Select Finish. You will be asked if you want to save the growth parameters to a file;
you can select No.

Figure 2.51 Crack Growth Analysis wizard – second panel.
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Figure 2.52 Crack Growth Analysis wizard – third panel.

Figure 2.53 Crack Growth Analysis wizard – fourth panel.
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Step 8.4: Specify Fitting and Template Parameters

The fifth panel, Fig 2.54, lets us set the crack front fitting and mesh template parameters. Use
the default 3rd order polynomial and 3% extrapolation. Set the template radius to an absolute
value of 0.1. Select Next.

Figure 2.54 Crack Growth Analysis wizard – fifth panel.

Step 8.5: Specify Growth Plan

The sixth panel, Fig 2.55, lets us define the amount of extension for each step of crack growth.
Set the number of steps to five and the constant median extension to 0.2. Select Next.
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Note that we are taking a relatively large crack growth step; this is to limit the number of steps
and time for this tutorial. Large steps can sometimes lead to issues with oscillations in the shape
of the crack fronts (see Section 9 of the User’s Guide), but for this model 0.2 is acceptable.

Figure 2.55 Crack Growth Analysis wizard – sixth panel.

Step 8.6: Specify Analysis Code

The seventh panel, Fig 2.56, shows that ANSYS is the solver. The Current crack growth step
defaults to 0 – representing the initial crack. (If we “manually” propagated the crack first, we
should set this to 1.) FRANC3D will extend the initial crack based on the growth rule defined in
the previous panels, and then name the resulting set of files as
Ansys_Cube_Subdivide_STEP_001.*. Subsequent file names have the step number incremented
as the automatic analysis proceeds. Select Next (button not shown in Fig 2.56).
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Figure 2.56 Crack Growth Analysis wizard – seventh panel.

The eighth panel, Fig 2.57, shows the analysis settings. Some options will be specific to your
site. You should have already set the ANSYS executable path in the FRANC3D Preferences.
The Global model settings should be set automatically. The local + global connection is
displayed in the next panel. Select Next.

Figure 2.57 Crack Growth Analysis wizard – seventh panel.
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The ninth panel, Fig 2.58, displays the local + global connection. The default settings use nodemerging of the cut-surfaces between the local and global portions. Select Finish to start the
automated crack growth process.

Figure 2.58 Local + Global connection options

FRANC3D saves the .fdb, .cdb and other files for the first crack step model with the name
Ansys_Cube_Subdivide_STEP_001, and then ANSYS starts in the background. If the analysis
stops at any stage, it can be restarted from the last crack step. All the required restart _STEP_#
files are retained. The model for any step can be read into FRANC3D to view the SIFs or to
restart the analysis with a modified crack growth increment (for example).
A summary of the various files can be found in Section 3 of the User’s Guide.
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2.9

Step 9: SIF History and Fatigue Life

Once the automatic crack growth analysis from Step 8 has finished, the stress intensity factor
history can be displayed. If you still have FRANC3D open and the crack growth from Step 8 is
done, you can proceed with Step 9.1. Otherwise, you can restart FRANC3D and read in the .fdb
file for the last step, using the File → Open menu option.

Step 9.1: Select SIFs Along a Path
From the FRANC3D menu, select Cracks →SIFs Along a Path, Fig 2.59. If the SIFs have not
been computed yet, the Compute SIFs dialog (see Fig 2.50) will be displayed; leave the defaults
and select Finish.

Figure 2.59 SIFs Along a Path menu option
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The Stress Intensity Factors (along a path) dialog should appear, Fig 2.60. The crack fronts are
displayed on the left along with the path through the fronts; the SIF history along the path is
shown in the graph on the right. You can use the tabs above the graph to plot the Mode II and III
SIFs as well as the elastic J-integral and T-stress values along the path. You can define a new
path, Fig 2.61. You can export the data also; for example, you might need to export the Mode I
SIF history (K vs a) to compute fatigue cycles using a different program. The exported data files
are ASCII txt files.

Figure 2.60 SIFs Along a Path dialog – KI plot

Step 9.2: Select SIFs For All Fronts
From the FRANC3D menu, select Cracks →SIFs For All Fronts. If the SIFs have not been
computed yet, the Compute SIFs dialog will be displayed; leave the defaults and select Finish.
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Figure 2.61 SIFs Along a Path dialog – Define Path
The Stress Intensity Factors (for all fronts) dialog should appear, Fig 2.62. The crack fronts are
displayed on the left and the SIFs for all crack fronts are displayed on the right. You can use the
tabs above the plot to display Mode II and III SIFs as well as the elastic J-integral and T-stress
values. If there are multiple crack fronts or multiple load steps, these can be selected using the
drop-down lists; this will be seen in subsequent tutorials.

Figure 2.62 SIFs for all Fronts dialog – KI plot
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Step 9.3: Select Fatigue Life Predictions

Fatigue life or cycles can be computed next. From the FRANC3D menu, select Fatigue
→Fatigue Life Predictions, Fig 2.63. If the SIFs have not been computed yet, the Compute
SIFs dialog will be displayed; leave the defaults and select Finish.

Figure 2.63 Fatigue Life Predictions menu option

The Fatigue Life dialog should appear as in Fig 2.64. The crack fronts are displayed on the left
and the window on the right side should be blank (assuming that lifing parameters have not been
defined previously). You must Set (or Read) Parameters. Selecting Set Parameters displays
the dialog shown in Fig 2.65.
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The units are MPa and mm; select the Change button to display the dialog in Fig 2.66 and set the
units to MPa and mm; select Accept.

Figure 2.64 Fatigue Life dialog

Figure 2.65 Fatigue Life parameters
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The FEM units can also be set in the main FRANC3D window using the Edit menu.

Figure 2.66 FEM units dialog

The crack growth load schedule is defined next. Select the New Schedule button (see Fig 2.65)
to display the dialog in Fig 2.67. Select the Schedule and then select the Add button; see right
side image of Fig 2.67. This will display the dialog shown in Fig 2.68; we use a simple cyclic
load schedule where the applied load produces Kmax and Kmin is zero. Select Accept to return
to the Load Schedule, Fig 2.69.

The stress ratio is set to 0.0. There is only one load case, which represents the Kmax condition.
The Repeat count is set to FOREVER. Select Accept to finish the load schedule. There is only
one event in the schedule so the repeat forever can be set for either the event or the schedule.
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Figure 2.67 New Load Schedule dialog

Figure 2.68 Event type dialog

53

Figure 2.69 Simple cyclic load schedule repeated forever

The crack growth rate model is defined next. Select the New Model button (see Fig 2.65) to
display the dialog in Fig 2.70. Choose the cyclic loading growth rate model, and select Next to
display the dialog in Fig 2.71.

Figure 2.70 Growth model type dialog
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Figure 2.71 Cyclic loading growth model dialog

We use a Paris growth model, which is the default; select Next to display the dialog in Fig 2.72.
The growth rate model will be temperature independent. Select Next to display the Paris growth
model dialog, Fig 2.73.

Figure 2.72 Temperature dependent or independent growth rate model dialog
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Figure 2.73 Paris growth rate model dialog
First, set the units for the Paris growth model. Select the Change button to display the Units
dialog, Fig 2.74. Set the units the same as the FEM units that we set earlier, which were MPa
and mm. If your growth model units are different from the FEM units, FRANC3D will do the
unit conversions automatically. Select Accept.

Figure 2.74 Paris growth rate model units
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In the Paris growth model dialog, click on the fields for C, n, DKth and Kc and enter the
appropriate values, Fig 2.75. Select Next to return the main dialog (see Fig 2.65). Other options
are left at their default values; select Accept to return to the Fatigue Life dialog, Fig 2.76.

Figure 2.75 Paris growth rate model values

Figure 2.76 Fatigue life dialog showing Cycles vs Crack Growth Step
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Note that the Paris exponent ‘n’ is set to 3 whereas we used n=2 for the quasi-static growth. In
practice, you can use the fatigue model and material data during the growth, so that growth is
consistent with the fatigue life computations done here. However, it is not strictly necessary as
fatigue cycles are recomputed here.

If we choose to plot cycles based on a path, we must select the Path radio button and then the
Define button to create a path, Fig 2.77. The default path is through the crack front midpoints.
Once a path is defined, the cycles versus crack path length is displayed, Fig 2.78.

Figure 2.77 Define crack path dialog

Figure 2.78 Fatigue cycles versus crack length
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2.10 Step 10: Resume Growth with Larger Submodel
We used a local submodel for the crack growth simulation. If the crack growth exceeds the
boundary of the local submodel, a larger submodel can be selected and crack growth can be
continued without having to restart the simulation from the beginning. In this step, we describe
the process of extracting the current crack geometry and inserting this crack into a larger portion
of the model to resume crack growth.

Step 10.1: Extract and Save Crack Geometry

The crack geometry information for each step of crack growth is saved in the FRANC3D restart
(.fdb) file. The data appears in this block:
FLAWSURF
(
VERSION: 5
NUM_SURFS: 763
SURF: 0
263 264 356
6.83559456365193
…
…
4.73891556707121
)

5.00380971299962

9.72712346638146

5.00420103803897

8.3468309877949

This data can be copied from the .fdb file and saved to a .crk file, using any text editor.

We open the Ansys_Cube_subdivide_STEP_005.fdb file, copy the FLAWSURF data, and save it
to a .crk file, called Ansys_Cube _step_5.crk.

At step 5, the crack is approaching the boundary of the submodel region, Fig 2.79, so we could
not have grown the crack much further.
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Figure 2.79 Crack step 5 in local submodel.

Step 10.2: Restart from Saved Crack Geometry
Start FRANC3D, and from the menu select File →Import. We could extract a larger submodel
region from the cube, but for this tutorial, we will just import the full cube model and run
subsequent crack growth simulations using the full model.

Select Import a complete model from the dialog, Fig 2.80, set the Mesh File Type to ANSYS,
and select the Ansys_Cube.inp file, Fig 2.81. Select Accept to continue.
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Figure 2.80 FRANC3D model import dialog.

Figure 2.81 FRANC3D mesh import file selector.

Note: if you choose to create a larger local submodel instead of using the full model, make sure
you edit the local and global file names so that you do not overwrite for the first set of local and
global model files (see the dialog in Fig 2.16).

Use the Select All button in the next dialog, Fig 2.82, to retain all the mesh facets where
boundary conditions are applied. Select FINISH when ready; the model will be imported and
displayed in the FRANC3D main window (see Fig 2.8). You will need to set/accept the units,
and then set/accept the work directory.
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Figure 2.82 Use Select All button to retain all highlighted mesh facets.

From the FRANC3D menu, select Cracks and Flaw From Files. Select the
Ansys_Cube_step_5.crk file, which was extracted from the .fdb file. The .crk file is read and then
displayed in the Orient User Flaw dialog, Fig 2.83. Note that the crack geometry includes the
original circular crack and all the subsequent steps of growth. Also note that part of the crack
geometry falls outside the model so that intersections can be computed correctly. In general, a
crack that is read from a file can be translated in Cartesian space, but for continuing crack
growth, we want the exact same location.

Select Next to set the mesh template parameters, Fig 2.84; we just use the defaults. Select
Finish when ready; the crack will be inserted and the model remeshed.
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Figure 2.83 Step 5 crack geometry displayed in cube model.

Figure 2.84 Step 5 crack mesh template.

From the FRANC3D menu, select Static Crack Analysis and set the analysis parameters; use
the same settings as in Step 5. The only thing that is changed is the file name so that we do not
overwrite the original submodel step files; call it Ansys_cube_full_STEP_005.
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The analysis should produce SIFs that are almost identical to the SIFs computed for the step_005
using the local submodel region. Fig 2.85 shows the Mode I SIFs for the two cases. There are
minor differences as the mesh around the crack front is different. At this stage, the crack can be
propagated further; do another six steps of crack growth using the same growth increment of 0.2.

Figure 2.85 Step 5 Mode I SIFs for the original submodel analysis (top) compared with the new
results using the full model (bottom).
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After propagating the crack an additional six steps, we can combine the SIF history for the two
analyses. We do this in the next step using the Advanced menu option Create Growth History.

Step 10.3: Combine SIF Histories
Start FRANC3D, select the File →Open menu option, and select the
Ansys_Cube_sub_STEP_005.fdb file. From the Advanced menu, select Create Growth
History, Fig 2.86. The dialog shown in Fig 2.87 is displayed. Note that the initial crack is
labeled as CrackStep_1 and then there are five steps of growth after that. You can use the Plot
menu command to display the crack fronts, Fig 2.88.

Figure 2.86 FRANC3D Advanced menu.

Using the File menu in the Create Growth History dialog, select Save History, Fig 2.89, and
save the SIF history to a .fcg file, called Ansys_Cube_sub_steps.fcg here. Close the dialog using
the Cancel button, and then close the model in FRANC3D using the main File menu Close
option.
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Figure 2.87 Create Growth History dialog – submodel data.

Figure 2.88 Create Growth History dialog.
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Figure 2.89 Create Growth History dialog File menu.

Now open the Ansys_Cube_full_STEP_011.fdb file (our last step of crack growth) using the File
menu Open option. As with the submodel, save the history using the Create Growth History
dialog. The SIF history for the full model is shown in Fig 2.90. Note that CrackStep_1 in the
full model gives the same SIFs as CrackStep_6 in the submodel; however, CrackStep_1 in the
full model includes crack extension data.

Figure 2.90 Create Growth History dialog – full model data.
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Save the full model SIF history to a .fcg file, called Ansys_Cube_full_steps.fcg. Close the Create
Growth History dialog and close the model. This leaves the FRANC3D main model window
empty. Select the Advanced and Create Growth History menu option to display the dialog. It
does not have any CrackGrowthData.

Use the File menu in the Create Growth History dialog and select Read History, Fig 2.91.
Select the Ansys_Cube_sub_steps.fcg file. Then using the same menu, select Append History
and select the Ansys_Cube_full_steps.fcg file. Note that there will be twelve steps of crack data
at this stage, Fig 2.92. We need to delete CrackStep_6 from the Submodel data as it does not
include extension data. We highlight CrackStep_6, Fig 2.92, and then right-click the mouse to
display the submenu, Fig 2.93. Select Delete Crack Step and it will be removed, leaving eleven
crack steps. You can plot the combined fronts, Fig 2.94.

Figure 2.91 Create Growth History dialog – File menu.

Figure 2.92 Create Growth History dialog – combined SIF history data.
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Figure 2.93 Right-mouse button click on the CrackStep_6 to delete.

Figure 2.94 Create Growth History dialog – combined crack fronts.

Use the File menu in this dialog (Fig 2.92) to save the combined SIF history to a .fcg file, called
Ansys_Cube_combined_steps.fcg. The dialog can be closed by selecting the Cancel button at the
bottom; selecting the Save button prompts you save the history data to file.

The combined SIF history data can be imported into the Fatigue Life module using the Read SIF
Data button, Fig 2.95. Once you have Set Parameters, you can plot cycles; see Step 9.3.
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Figure 2.95 Fatigue Life dialog.
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Appendix A:
ANSYS Workbench
A.1 APDL Commands in Workbench
ANSYS Workbench combined with APDL commands can be used to create .cdb files that can be
used in FRANC3D. A simple plate model is constructed in Workbench, Fig A-1, with two
regions, Fig A-2. The small central region is defined to create a local model for FRANC3D; in
practice, the local region can be extracted with FRANC3D without having to define two regions
in Workbench. Fig A-3 shows the APDL commands that are added to Workbench to write the
.cdb files. Three .cdb files are created; the BOXALL.cdb will be the full model and could be
imported and divided in FRANC3D. Alternatively, the BIG_BOX.cdb and SMALL_BOX.cdb
files could be imported as “already divided”.

Figure A-1 Workbench Interface.
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Figure A-2 Workbench model of a simple plate.

Figure A-3 Workbench APDL commands to write .cdb files.
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A slightly more complicated process and model is described next. A model is created in
Workbench and a Mechanical APDL is linked to the setup, Figs A4-A6. This is used to edit the
model in ANSYS Classic to create the .cdb files if commands in Workbench are not used.

Mechanical APDL
linked to Setup, Use
right click and Edit
in Mechanical
APDL

Figure A-4 Workbench interface to ANSYS Classic.

Figure A-5 Example model with temperatures, pressures, forces, contacts, and cyclic symmetry
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Named Local and
Global Models

LOCAL_MODE
L

Commands to
export Local and
Global CDB files

Figure A-6 Model Defining the Local and Global Models

The following method was used to create the local and global .cdb files for use in FRANC3D.

ANSYS:
1. Create model in Workbench
a. Set up coordinate systems
b. Name parts as GLOBAL_MODEL, LOCAL_MODEL, and INTERFACE
c. Add Temperatures, Pressures, Forces, Contacts, etc.
d. Add Boundary Conditions
e. Use consistent Units
2. Link APDL to Setup of Structural Model
a. Edit Mechanical in APDL (This will launch ANSYS Classic)
3. In Ansys Classic the following commands (with potential modifications) will be needed
to create the CDB files or add commands to the Workbench Mechanical Setup:
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Ansys Workbench:
- materials
- geometry (sub-models)
* Global model
* Local model
* Interface
- coordinate systems
- loads, mission
- boundary conditions
-APDL commands
- Change Units (EMUNIT)
- Check Jacobian values
- add SHPP,OFF

Global_Model

Remove CYCLIC commands,
Add SHPP, OFF
Add CYCLIC,,,,’CYCLCIC’
Move Coord System to Top

Find Max Node and
Cosines (PRVECT)

Local_Model, using
SLICE, single part
Define Crack
Move Coord to Top
Remove all other Tables

FRANC3D

Interface_Section
SIF

ANSYS CLASSIC APDL CLICKS/COMMANDS:
→Select→Everything
CDWRITE,DB,F3D_FULL_MODEL,CDB
CMSEL,U,LOCAL_MODEL
NSLE
CDWRITE, DB,F3D_GLOBAL_MODEL,CDB
CMSEL,,LOCAL_MODEL
NSLE
CDWRITE, DB,F3D_LOCAL_MODEL,CDB
ANSYS WORKBENCH APDL COMMNADS:
ALLSEL,ALL,ALL
CDWRITE,DB,D:\ F3DMODELS\DOVETAIL\F3D_FULL_MODEL,CDB
ALLSEL,ALL,ALL
CMSEL,U,LOCAL_MODEL
NSLE
CDWRITE,DB,D: \F3DMODELS\DOVETAIL\F3D_GLOBAL_MODEL,CDB
ALLSEL,ALL,ALL
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CMSEL,,LOCAL_MODEL
NSLE
CDWRITE,DB,D:\ F3DMODELS\DOVETAIL\F3D_LOCAL_MODEL,CDB
ALLSEL,ALL,ALL
GLOBAL MODEL FILE EDITS:
The following was changed in the GLOBAL_MODEL.CDB file:
1. REMOVED the following lines in the CDB file:
*DIM,_CYCLICMAP ....
*SET,_CYCLICMAP ....
CYCL,CDWR ....
2. ADDED the following Element Shape Checking Command:
SHPP,OFF
3. ADDED the following lines in the CDB file before the /GO and /FINISH Commands:
CYCLIC,,,,'CYCLIC'

A.2 Workbench ds.dat File
ANSYS Workbench creates a ds.dat file when the model is submitted for analysis. This file
contains all the model data and is an ASCII file, so it can be edited. A simple method of creating
a .cdb file, is to edit the ds.dat file and add a cdwrite command. The edited file can be processed
by ANSYS and a .cdb file will be written.

FRANC3D can process a .db or a .dat file directly during the GUI import. A working ANSYS
version must be accessible as FRANC3D will execute ANSYS in the background to convert
these files into .cdb files. The resulting .cdb file is then imported. The process is briefly
described here.

Starting with a ds.dat file from WB, use the FRANC3D Import and divide option, Fig A-7.
Choose the ds.dat file, Fig A-8, after changing the File type filter. Once the file is selected, click
Next; ANSYS runs in the background to create a cdb file along with .s## files, Fig A-9.
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Figure A-7 Import and divide selected.

Figure A-8 Change the File type and select the ds.dat file.

Figure A-9 ANSYS is used to create .cdb and .s## files from the ds.dat file.
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When ANSYS finishes, FRANC3D automatically imports the .cdb and .s## files into the
Subdivided model dialog, Fig A-10. One can then cut out a local model, and save the Local and
Global .cdb files, Fig A-11. The Local and Global cdb files will contain the relevant boundary
condition data and load steps.

Figure A-10 FRANC3D submodel dialog.

Figure A-11 FRANC3D dialog for saving the LOCAL and GLOBAL cdb files.
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Appendix B:
Python Script to Add/Modify ANSYS CP Data
ANSYS CP (coupled degrees of freedom) data is usually passed through by FRANC3D. It is
best to have all the nodes with CP data in the “global” model portion, but in some cases, one
might need to have some of the nodes with CP data in the “local” model portion. In this case, the
surface mesh facets should be retained for those CP nodes. The resulting cracked _full.cdb file
should be edited to recreate the CP data; this can be done using a simple Python script that will
run prior to ANSYS.

We will demonstrate this using a simple disk, Fig B-1. The boundary conditions include CP data
on the symmetry surfaces, Fig B-2. The nodes on the two symmetry surfaces are put into a
“cp_surfs” component (cmblock), which allows us to retain the nodes and mesh facets when we
import the model into FRANC3D.

Figure B-1 ANSYS disk geometry.
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Figure B-2 ANSYS CP on symmetry surface nodes.

B.1 Import Disk into FRANC3D
Start FRANC3D and select File and Import. In the Select Type of Import panel, choose the
Import and divide into global and local models radio button and select Next. Switch the Mesh
File Type radio button in the Select Import Mesh File window to ANSYS and select the file
name for the model, called disk_CP.cdb, Fig B-3. Select Next.

Figure B-3 FRANC3D FE model import.

Create a local model using the Rubberband Box tool in the Define Local Submodel window, Fig
B-4. Select Next after using the Crop button and then save the local and global model files
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using the default file names. In the Select Retained BC Surfaces window, Fig B-5, use the Show
Node Sets button to see the list of components and check the “cp_surfs” box. Select Finish
when ready to proceed. The model will be displayed in the FRANC3D main window, and we
are ready to insert the crack into the local model.

Figure B-4 FRANC3D FE model import.

Figure B-5 FRANC3D FE model import.
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B.2 Insert Initial Crack
We insert an elliptical crack with a radius of 0.1, Fig B-6. Note the surface mesh facets and
nodes are retained on the CP symmetry surfaces. This allows us to regenerate the CP data in
ANSYS as described in the next two sections.

Figure B-6 Crack inserted into local model.

B.3 Create Python Script
We need to create a Python script that will modify the _full.cdb file that is written during the
next step. A sample script is shown here.

#!/usr/bin/python
import sys
import string
if __name__ == '__main__':
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fname = sys.argv[-1]
# read the input file
fdi = open(fname,'r')
buff = fdi.readlines()
output = []
for lb in buff:
if len(lb) > 0 :
if lb[0] == '/' or lb[0] == '!' :
str = lb
vals = str.split()
if vals[0].upper() == '/SOLU' :
output.append(lb)
cpdel = "CPDEL,all,all\n"
output.append(cpdel)
cpcyc = "CPCYC,UY,0.001,1,0,90,0\n"
output.append(cpcyc)
continue
output.append(lb)
fdi.close()
fdo = open(fname,'w')
for lo in output:
fdo.write("%s"%(lo))
fdo.close()
The Python script reads the file and then iterates through the lines looking for the ‘/SOLU’
string. When it finds this string, the CP commands are added, which will cause ANSYS to delete
and then recreate the CP data. The file is overwritten with the edited information.

Note that the Python script operates on the _full.cdb file prior to running ANSYS; this is
described next.

B.4 Static Crack Analysis
We perform a static crack analysis using ANSYS. Choose Analysis and Static Crack Analysis
from the FRANC3D menu. Provide a file name (disk_cp_crack.fdb) and choose ANSYS as the
solver. The ANSYS options are shown in Fig B-7. The ANSYS executable and license string
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should be set for your installation. The Python executable can be found using the Browse button
if it is not in your PATH environment variable. The Python script can be set using the Browse
button. We have saved the script from the previous section to a file: editAnsysCdb.py.

The Connect to global model option is checked automatically, and the global file name is set.
Select Next to continue. The next dialog box, Fig B-8, has options for connecting the local and
global portions. We use node merging with the automatically selected local and global cutsurfaces.

Figure B-7 Static analysis options for ANSYS with Python script provided.
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Figure B-8 Static analysis ANSYS local + global model connection dialog.

Click Finish to begin the process of running Python followed by the ANSYS analysis.

You can verify that the _full.cdb file was edited correctly, Fig B-9. You can also verify that the
ANSYS solution is correct, Fig B-10.

Figure B-9 Portion of the _full.cdb file with CP commands added.
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Figure B-10 ANSYS _full.cdb model showing CP data (left) and deformed shape (right).

B.5 Compute SIFs
Once ANSYS has finished running, we compute the SIFs; choose Cracks and Compute SIFs
from the FRANC3D menu. The dialog, Fig B-11, allows you to specify the method for
computing SIFs. If you use the M-integral, you can make sure that the Include Thermal Terms
option is checked, and that the Reference Temperature is 0 degrees by clicking the Advanced
button.

The SIFs based on the M-integral are shown in Fig B-12. The SIFs should match the

SIFs from Tutorial #4, which uses roller boundary conditions on the symmetry surfaces.

Figure B-11 Compute SIFs dialog.
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Figure B-12 M-Integral based SIFs.
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Appendix C: ANSYS Model with Extra Load Steps
When importing and dividing an ANSYS model with extra load step files, it is important to note
that the extra loads will be added to both LOCAL and GLOBAL .cdb files. Fig C.1 shows the
sequence of import dialogs for an ANSYS model with two extra load step files.
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Figure C.1 Sequence of dialogs for importing and dividing an ANSYS model with two .s## files.

To verify that the extra load step information is included, we can open the GLOBAL .cdb file
and search for “_lsnum=” commands. For example:

allsel,all,all
/SOLU
_lsnum= 1
solve

The _lsnum provides the FRANC3D load step ID. The original Ansys_Cube.cdb file contains
one load step and the .s02 and .s03 files each contain one load step; these could correspond with
arbitary ANSYS load steps, but FRANC3D will renumber internally. Older versions of
FRANC3D, used ANSYS “lswrite” and “lssolve” commands.

The user should not include the extra .s## files if the local and global model files are imported
again (as an already divided model). The Extra load files check box, Fig C.1, is not available
when importing using the “already divided” option.

Tutorial #2 uses multiple load steps, and the ANSYS version of the model has two extra load
step files. If you decide to create your own local and global portions outside of FRANC3D, then
it is important that you put all the load step information for each portion in the appropriate .cdb
file. FRANC3D needs to keep track of the load steps and needs to recombine the cracked-local
with the global portion; this can only be done if all information is contained in the .cdb files.
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Appendix D: ANSYS Keywords
The list of ANSYS keywords that FRANC3D recognizes is provided here. FRANC3D must
process some of the data, but a large amount of the .cdb file can be passed through to the
_GLOBAL.cdb and then to the _full.cdb, which is the combination of the cracked/remeshed
portion of the model and the _GLOBAL.cdb portion.

dispatch.Store(String("/COM"), &AnsysCdbReader::Comment) ;
dispatch.Store(String("/TITLE"), &AnsysCdbReader::Title) ;
dispatch.Store(String("*SET"), &AnsysCdbReader::sSet) ;
dispatch.Store(String("*DIM"), &AnsysCdbReader::sDim) ;
dispatch.Store(String("*IF"), &AnsysCdbReader::IfEndif) ;
dispatch.Store(String("ET"), &AnsysCdbReader::Et) ;
dispatch.Store(String("KEYOP"), &AnsysCdbReader::Keyop) ;
dispatch.Store(String("LOCAL"), &AnsysCdbReader::LocalCoordSys) ;
dispatch.Store(String("N"),
&AnsysCdbReader::SingleNode) ;
dispatch.Store(String("NBLOCK"), &AnsysCdbReader::NodeBlock) ;
dispatch.Store(String("EN"), &AnsysCdbReader::SingleElem) ;
dispatch.Store(String("EBLOCK"), &AnsysCdbReader::ElemBlock) ;
dispatch.Store(String("MPTEMP"), &AnsysCdbReader::MPTemp) ;
dispatch.Store(String("MPDATA"), &AnsysCdbReader::MPData) ;
dispatch.Store(String("MP"), &AnsysCdbReader::MP) ;
dispatch.Store(String("TB"), &AnsysCdbReader::TBData) ;
dispatch.Store(String("_LSNUM"), &AnsysCdbReader::LSNum) ;
dispatch.Store(String("_LSNUM="),&AnsysCdbReader::LSNum) ;
dispatch.Store(String("LSWRITE"),&AnsysCdbReader::LSWrite) ;
dispatch.Store(String("D"),
&AnsysCdbReader::DispBC) ;
dispatch.Store(String("F"),
&AnsysCdbReader::ForceBC) ;
dispatch.Store(String("SFE"),
&AnsysCdbReader::PressBC) ;
dispatch.Store(String("SFEBLOCK"), &AnsysCdbReader::PressBC) ;
dispatch.Store(String("SFGRAD"), &AnsysCdbReader::Sfgrad) ;
dispatch.Store(String("BFBLOCK"),&AnsysCdbReader::BFBlock) ;
dispatch.Store(String("BF"), &AnsysCdbReader::BodyForceBC) ;
dispatch.Store(String("BFE"), &AnsysCdbReader::BodyForceEBC) ;
dispatch.Store(String("BFUNIF"), &AnsysCdbReader::BodyForceUnif) ;
dispatch.Store(String("TREF"), &AnsysCdbReader::TempRef) ;
dispatch.Store(String("TIME"), &AnsysCdbReader::TimeBC) ;
dispatch.Store(String("CMBLOCK"),&AnsysCdbReader::CompBlock) ;
dispatch.Store(String("DDEL"), &AnsysCdbReader::DelDisp) ;
dispatch.Store(String("DDELE"), &AnsysCdbReader::DelDisp) ;
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dispatch.Store(String("SFEDEL"), &AnsysCdbReader::DelSfe) ;
dispatch.Store(String("SFEDELE"),&AnsysCdbReader::DelSfe) ;
dispatch.Store(String("FDEL"), &AnsysCdbReader::DelForce) ;
dispatch.Store(String("FDELE"), &AnsysCdbReader::DelForce) ;
dispatch.Store(String("BFDEL"), &AnsysCdbReader::DelBf) ;
dispatch.Store(String("BFDELE"), &AnsysCdbReader::DelBf) ;
dispatch.Store(String("LSCLEAR"),&AnsysCdbReader::LsClear) ;
dispatch.Store(String("NLDIAG"), &AnsysCdbReader::Nldiag) ;
dispatch.Store(String("ANTYPE"), &AnsysCdbReader::AnType) ;
dispatch.Store(String("NSUBST"), &AnsysCdbReader::NSubSt) ;
dispatch.Store(String("NSUBS"), &AnsysCdbReader::NSubSt) ;
dispatch.Store(String("SOLVE"), &AnsysCdbReader::Solve) ;
dispatch.Store(String("SOLV"), &AnsysCdbReader::Solve) ;
dispatch.Store(String("LSSOLVE"),&AnsysCdbReader::LsSolve) ;
dispatch.Store(String("CDWRITE"),&AnsysCdbReader::CdWrite) ;
dispatch.Store(String("EXTOPT"),&AnsysCdbReader::Ignore) ;
// this is passed through, but we need to process to count load steps
dispatch.Store(String("ACEL"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("OMEGA"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("DOMEGA"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CGLOC"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CGOMEGA"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("DCGOMG"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CMOM"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CMOMEGA"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CMDO"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CMDOMEGA"),&AnsysCdbReader::Omega) ;
dispatch.Store(String("CMRO"), &AnsysCdbReader::Omega) ;
dispatch.Store(String("CP"),

&AnsysCdbReader::CoupleDof) ;

// currently this is passed through
dispatch.Store(String("CE"),
&AnsysCdbReader::ConstraintEqn) ;
dispatch.Store(String("CERIG"), &AnsysCdbReader::ConstraintEqn) ;
dispatch.Store(String("SECTYPE"), &AnsysCdbReader::Pretension) ;
dispatch.Store(String("SECDATA"), &AnsysCdbReader::Pretension) ;
dispatch.Store(String("SECMODIF"),&AnsysCdbReader::Pretension) ;
dispatch.Store(String("CYCLIC"), &AnsysCdbReader::Cyclic) ;
dispatch.Store(String("CYCL"), &AnsysCdbReader::Cyclic) ;
// we generate ansys commands to create contact
// we are using cmsel as the dispatch key for this
dispatch.Store(String("CMSEL"), &AnsysCdbReader::Cmsel) ;
dispatch.Store(String("/PREP7"), &AnsysCdbReader::Prep) ;
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dispatch.Store(String("/SOLU"), &AnsysCdbReader::Solu) ;
dispatch.Store(String("/SOLUTION"),&AnsysCdbReader::Solu) ;
dispatch.Store(String("/POST1"), &AnsysCdbReader::Post) ;
dispatch.Store(String("FINISH"), &AnsysCdbReader::Finish) ;
dispatch.Store(String("FINI"), &AnsysCdbReader::Finish) ;
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